Mazda3 Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
99 Posts
Discussion Starter · #1 ·
Hello, I've got a 2005 Mazda3 hiboost sedan w/ 2.3l engine, MTX. I just had an Exedy stage 1 clutch put in, and while taking it home I noticed that there was a weird noise (loud, noticeable, coming from the engine bay) like air was escaping somewhere when under boost. The noise that sounds like air rushing even overpowers the sound of the turbo spooling sometimes.

It seems fine, it drives normal and I don't notice a lack of power, however the noise worry's me. I also noticed that on top of the engine there is a like small hole/pipe/exit that is releasing air, and you can feel the air when you move your hand over. The hole is part of the engine but I never noticed it before, it looks like the hole had a cap on it because there are 2 plastic threadlike hooks on it, its now just a naked hole going into the engine.

Also, I noticed that randomly when I'm under boost I hear another noise that almost sounds like its in the cab, its a loud kind of whine -- not sure if its the fuel pump or what but it happens randomly and it never happened before the clutch install, neither did the air noise in the engine bay.

I don't know weather they to decided to take it for a joyride and blew something but I'm really worried. FYI I come here a lot and read topics but I never really have a reason to post a topic, until now. I used the search for a while before posting this and couldn't find anything related.

Tom
 

·
Registered
Joined
·
99 Posts
Discussion Starter · #2 ·
No one can think of anything? I was examining the car today and I noticed some IC piping was loose below the turbo and that the air was leaking out of the pipe. I think this is why I heard the noise, and I also think the fuel pump is acting up because of the lack of air before the MAF sensor. Not sure if this is the problem yet. Are these signs of a boost leak?
 

·
Registered
Joined
·
501 Posts
I would say yes they are probably signs of a boost leak. If you find a performance shop near you they might be able to test for boost leaks. I had a buddy who went to get his car tuned and they found lots of boost leaks. Mostly from bad silicone connectors. Tighten up any loose connectors and re check all your boost tubes. ( they might have taken your car for a joy ride. I don't trust shops that are not like a jiffy lube, mienike. or a professional performance shop. They always do weird stuff with your car if it has mods.)
 

·
Registered
Joined
·
99 Posts
Discussion Starter · #4 ·
Well I took it back to the place I got the clutch put in. They looked over all the inter cooler piping and found that a pipe coupler was indeed loose/not tightened all the way. It was the connector about 6-8" below the turbo itself. They tightened it back up and everything seems to be working excellent now. Thanks for the help. :p
 
1 - 4 of 4 Posts
Top