Mazda3 Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 2010 mazdaspeed3 with just a cold air intake and without the Cobb accessport, but it has been overboosting and running lean, and I have ran it like that for months now, but today when I was pushing it on the highway I had a sudden loss of power, I pulled over and felt the engine running super rough, I took it to O’Reilly’s and pulled some codes.
Light Product Gadget Communication Device Reflex camera
Light Gadget Communication Device Font Portable communications device
Light Communication Device Gadget Font Portable communications device
Light Product Gadget Communication Device Font

Need help on figuring out what to look for to fix.
 

·
Registered
Joined
·
281 Posts
How long have you had the P0128? I wonder if your thermostat has long been stuck open...

Regardless, it otherwise seems the prolonged lean condition may have lead to cylinder/head hotspots and headgasket failure. You may now know that white smoke is ominous for coolant burning, and the only way that gets into a cylinder is past the headgasket. P0139 can be borne of insufficient compression. As @m3iguy said, a compression test will confirm failure; you'll then need to decide whether you want to rebuild or replace.

If you decide to stay with that vintage of Speed, you may find this article interesting (and protective?): Blog : Stratified Automotive Controls
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
How long have you had the P0128? I wonder if your thermostat has long been stuck open...

Regardless, it otherwise seems the prolonged lean condition may have lead to cylinder/head hotspots and headgasket failure. You may now know that white smoke is ominous for coolant burning, and the only way that gets into a cylinder is past the headgasket. P0139 can be borne of insufficient compression. As @m3iguy said, a compression test will confirm failure; you'll then need to decide whether you want to rebuild or replace.

If you decide to stay with that vintage of Speed, you may find this article interesting (and protective?): Blog : Stratified Automotive Controls
I have had the problem with running lean and my maf sensor freaking out because of the cold air intake I put on without the accessport. I’ve been running it like that for months now, and now it’s coming back at me.
 
1 - 4 of 4 Posts
Top