Mazda3 Forums banner

Lost steering


  • Total voters
    733
1261 - 1272 of 1272 Posts

·
Registered
Joined
·
708 Posts
That's too bad about the car, were you hurt? What was the repair estimate? It ended up costing nearly $4k to get my wifes car done.
NTM, my wife is still dealing with pain issues in her left hand(impact side).
Good luck, I hope they do a good job.
 

·
Registered
Joined
·
17 Posts
After glancing over this thread, I can understand why the Mazda 3 is a little on the expensive side to insure...

Every time one of these are involved in an accident, it's a red mark against this car with insurance companies, especially if the driver is the one at fault.

Geez people! Slow down and pay attention!

I really agree with the rant from an earlier post.
 

·
Registered
Joined
·
56 Posts
I got my Mazda3 three weeks ago. The end of this first week, some Jack ass cut across three lanes of traffic, and ran right into me. Nothing I could do. It seemed intentional. The guy was a few IQ points away from a dog. But we were all safe and unarmed and my car still works fine just looks fucked up.
 

·
Registered
Joined
·
708 Posts
Wow, here we go again! My wife gor rear-ended AGAIN! This is the third time she's been hit. No injury, super light hit. Bumper is crunched. And for a bonus, my little 4ft. 11inch tall wife made the guy cry! I actually felt sorry for him when she told me about it.
 

·
Registered
Joined
·
486 Posts
Just yesterday on my way home it was snowing and blah blah blah... so i was changing lane from second to first and when i did i saw this car in front with emergency flashing lights, i thought it was slowly moving but it was actually standing still so i kind a quick jumped back to second lane but never made it there cause of the snow and started to slide from one side to another and finally at low speed i still hit a curb with rear driver side wheel and front. I was able to drive home half mile and when i looked at it rear wheel was poking out top part and front wheel was slightly pushed forward. After i took both wheels of i could see that front lower control arm was out of place and rear one my best guess is that trailing arm is bent. Take a look at some pictures i did.
 

Attachments

·
Registered
Joined
·
190 Posts
After 200,000 miles it finally happened. My car isn't totaled and is fine but brand new winter tires with 8k blew up. Was the rear passenger tire. Was slowing down from 45mph and boom. Defective tire.

 

·
Registered
Joined
·
4 Posts
2011 SP25 - Clutch broken?

Hi, my name is Matt and I have a 2011 BL Series 1 SP25 MY10.

I was involved in a car crash and the driver's side front bumper took a big hit. I will need a new: side guard/front bumper/bonnet/wheel arch/fog light/headlight/sub frame (did its job and took most of the impact) and sub frame holder (part of the chassis). Not quite a write-off.

I have replaced the battery and the engine is running! However, the clutch does not work.. when the engine is off, I can change gears and hear them moving. When the engine is on I can also hear the gears moving. The problem is, when I take my foot off the clutch NOTHING HAPPENS. None of the gears are engaging. I've tried pumping the clutch with no luck.

So I'm not sure if it's the hydraulics (to the clutch)/ broken pressure plate/ or even cracked diaphragm. I don't think it's the flywheel.

My insurance was tragically out by a couple of weeks, and I didn't know because I forgot to change my address when I moved house. So I have to cop the full expense. I admit I don't know a lot about cars, but I am learning a lot. So I would really appreciate if you guys can give me some insight/help me get to the problem.
 

Attachments

·
Registered
Joined
·
486 Posts
Hi, my name is Matt and I have a 2011 BL Series 1 SP25 MY10.

I was involved in a car crash and the driver's side front bumper took a big hit. I will need a new: side guard/front bumper/bonnet/wheel arch/fog light/headlight/sub frame (did its job and took most of the impact) and sub frame holder (part of the chassis). Not quite a write-off.

I have replaced the battery and the engine is running! However, the clutch does not work.. when the engine is off, I can change gears and hear them moving. When the engine is on I can also hear the gears moving. The problem is, when I take my foot off the clutch NOTHING HAPPENS. None of the gears are engaging. I've tried pumping the clutch with no luck.

So I'm not sure if it's the hydraulics (to the clutch)/ broken pressure plate/ or even cracked diaphragm. I don't think it's the flywheel.

My insurance was tragically out by a couple of weeks, and I didn't know because I forgot to change my address when I moved house. So I have to cop the full expense. I admit I don't know a lot about cars, but I am learning a lot. So I would really appreciate if you guys can give me some insight/help me get to the problem.
So insurance didn't covered cause they didn't know your new address?

Did the air bags went off?

What did you hit?
 
1261 - 1272 of 1272 Posts
Top