Mazda3 Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
This is my first winter here in Fairbanks ALaska,and I usually drive my Corolla but the tags expired so my Wife and I have been driving our Mazda. Just recently I threw a CEL, and I was wondering if the weather is too cold for my CAI. Right now its around -20. Has anyone else had this happen? I know I've had a CEL for the stupid gas tank being open before so its not that.
 

·
Registered
Joined
·
14,227 Posts
I feel sooooo sorry for you haha....shit thats cold...none-the-less...that shouldn't be a problem. I just had a CEL...I reset the computer and it stayed off....I suggest you wait it out or reset. If it comes back on, then it's a problem to look more into. if it goes away...it's just prob something stupid.



*EDIT*I ment SHOULDN'T*EDIT*
 

·
Premium Member
Joined
·
2,719 Posts
its the same air your engine would be breathing anyways, the air temp isn't going to change a whole bunch from where your stock intake is compared to your CAI.

-20 is f*ing cold!!!
 

·
Registered
Joined
·
5,875 Posts
more than likely you sucked up a tiny bit of moisture and quenched the hot wire for the MAF, if the CEL says "MAF out of range", thats what you did, and you don't need to worry about it.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #9
Appreciate everyones help. Yeah I guess ill just reset it and see if that fixes the CEL if not Im gonna take it in. Yeah -20 is cold but once you get used to that when it gets around 0 thats warm! Unfortunately I still have 2 years of that too look foward too. People up here say this is actually a warm summer it can reach -60.
 

·
Registered
Joined
·
3,160 Posts
Haha, i'm like dying a frozen death when the temperature is 50 degrees F outside during harsh southern california winters.

This morning it was 8 degrees C and I was freezing my buns off, but at least it warmed up in a few minutes. (I set my climate control to 24 degrees C)
 

·
Registered
Joined
·
21 Posts
Discussion Starter #14
Yeah Im in the AIrforce. Sorry I meant winter, shoot if it got to -60 in the summer I'd hate to see what the winters are like.
 

·
Premium Member
Joined
·
2,719 Posts
[quote author=polynesianmutt link=topic=65992.msg1131457#msg1131457 date=1167860452]
Yeah Im in the AIrforce. Sorry I meant winter, shoot if it got to -60 in the summer I'd hate to see what the winters are like.
[/quote]

is there even a runway for an AFB up there? or is it just early warning radar stuff...? :shock:
 

·
Registered
Joined
·
2,313 Posts
-20!!! thats f**king cold!! but the good news is that ur CAI is sucking in all that cold air and in theory you should be getting a little more HP from it. :D
 

·
Registered
Joined
·
6,470 Posts
Have you checked all of the connections on your intake? I'd imagine that a loose clamp or something would be a lot more likely than the air being too cold for the engine. Those silicone couplings probably stiffen up a bit in extreme cold, not to mention that the thermal expand/contract cycles are going to be more extreme as well.

That's where I'd look first, anyways.

Or maybe a MAF sensor wire has been damaged? If the insulation were to get brittle and crack, then suddenly you have a place where the actual metal conductors are more likely to bend and break.
 
1 - 19 of 19 Posts
Top