Mazda3 Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter · #1 ·
I'll post pics later but:

4 x Eclipse SP8972 5x7" Mid-Range Component Speakers and Tweeters
1 x Eclipse PA5422 800w 4-Channel Amp
1 x JL Audio 10w3v2 - in a custom sealed MDF box
Phoenix Gold wiring
1 x Navone LOC

etc, etc.

Amp is mounted hidden under the passenger seat, can't see any wiring.. Sub's in right side of the trunk, can't see any wires there either.. Completely clean.

$1230 was total cost w/ installation. These guys did an awesome job and the set-up is bumpin' as hell.

Done by Lou at Sound Effects in Paramus NJ. Highly recommend these guys, they know way too much about audio, it's scary. ;)
 

·
Registered
Joined
·
88 Posts
That's awesome, can't wait to get my system installed. I'm so excited that I have purchased most of the audio equipment, and I still have to wait a couple more months for the car.

What do you think of your system without any rear fill?

Thanks and enjoy!
 

·
Registered
Joined
·
88 Posts
No, I mean rear speakers.
 

·
Registered
Joined
·
5,580 Posts
ok...let me get this straight. You have a 4 ch amp, 4 speakers and 1 sub. Your amp can't power all of them because you would need 5 ch. So what we are trying to say is that you probably have your amp powering the front speakers and your sub. The rear speakers are must be powered by the stock HU......Unless you have an aftermarket HU that we don't know about....
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top