Mazda3 Forums banner

1 - 7 of 7 Posts

·
Premium Member
Joined
·
209 Posts
Discussion Starter #1
Hey guys,

I had my DDE's running great until my HID's failed. I replaced the fuses and just as quick as I put them in they blew. I went through 2 sets of fuses just to make sure I didn't foul up the process. So, my question is, does anyone have any ideas?? Is it the ballasts? Something deep in the electrical system that keeps blowing the fuses??

I am taking my baby to the dealership to get looked at on Monday. I am just curious as to how many others have had similar situations??

Thanks,
Vince
 

·
Registered
Joined
·
11 Posts

·
Registered
Joined
·
9,483 Posts
check all the wires....

might be a short... or a grounded out wire somewhere?
 

·
Premium Member
Joined
·
209 Posts
Discussion Starter #4
I'm having the exact same problem, read my post I just started yesterday:

http://www.mazda3forums.com/index.php?topic=71582.0
I missed that one...sorry. I had a difference qoute from Pinnacle Mazda at 470 something for the ballast. He orginally said that I had to buy the whole kit which would have cost what you were qouted and then he realized they were sold seperately for the 04-05.

I am thinking about getting seperate ballasts and running them that way. It may ultimately be the cheapest as they new ballasts are about $250 a pair (aftermarket).
http://www.hidplanet.com/ballasts.html


I am still under warranty so hopefully they will say it is my fault, though I seriously doubt that.
 

·
Registered
Joined
·
11 Posts
Is it possible that the fuses being blown is caused by moisture getting inside the projector? In which case I would replace the HID's but have the same problem again so I'd need to seal the headlight better. Has this happened to anyone else?
 

·
Premium Member
Joined
·
209 Posts
Discussion Starter #6
I just re-re-reinstalled my DDE's and this time (after sitting in the rain for nearly 5 hours) no condensation and or leaks. Last time condensation was pretty quick. I honestly can't say what the problem is about the fuses. I will find out for sure on Monday.
 

·
Premium Member
Joined
·
209 Posts
Discussion Starter #7
BTW, has anyone tried aftermarket ballasts like the G-3 Hella/Phillips??? Will they work on stock HID's?
 
1 - 7 of 7 Posts
Top