Mazda3 Forums banner
1 - 4 of 4 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have the original head unit for my 2012 Mazda 3 skyactive. I was recently in a rearender and after having my car fixed by the auto body place I've been having issues with my stereo. The auto body place disconnected my battery multiple times to try reset the codes from the accident. After getting my car back, my stereo intermittently turns on and off sometimes for a brief second. Sometimes it's on for a day and then cuts in and out. When it cuts in an out. There's usually a large popping sound coming from the speakers. When it turns on you can hear the CD player starting up. I get the hello message on my little tiny screen and then it'll cut out again. The auto body place is claiming that it is nothing to do with them and was not a part of the accident and will not cover it. I'd never had issue with this and I've had this car for 7 years now. I do get that. The stereo is now 11 years old. But just seems like a heavy coincidence. Anybody have any ideas on how to rectify this? I have checked the audio fuse in the driver side fuse box and it is solid. Doesn't seem like it's faulty. Can't seem to think of what else to do? Besides, take it to a Mazda dealership. However electrical issues I know can be very hard to find and I don't have the money to spend chasing it. I've missed anything. Please ask and I'll try to answer as soon as I can. Thank you for your help in advance.
 

· Registered
Joined
·
2 Posts
Discussion Starter · #2 ·
Also forgot to mention that when I got my car back they said that it appeared that my battery was depleted and they had to put it on a tender to try charge it. I never had any battery issues previous to the rear ending either. Since getting my car back and driving it I haven't had any other electrical issues. I did notice when the stereo is turning on and off or kicking in and out that the lights on the head unit also blink on and off.
 
1 - 4 of 4 Posts
Top