Mazda3 Forums banner

1 - 20 of 31 Posts

·
Registered
Joined
·
177 Posts
Discussion Starter · #1 ·
So I noticed that my car was smoking a faint white smoke out of the exhaust. I figured it's a cold night, it's probably water vapor. I drive home (about 15 min) and let it sit in my garage in idle for 5-10 minutes. At first, when I parked my car, I didn't notice anything. However, after 5-10 minutes, the faint white smoke is back. The smoke disappears by the time it rises to the roof-level of the car. it's faint, but it's visible. However, if I step on the gas, it doesn't get any thicker or "whiter".

Is my turbo smoking? My mods are: turbosmart bov, fujita cai, and cpe downpipe with cat.
 

·
Registered
Joined
·
4,723 Posts
Get down and sniff it. If it smells like burning oil, then yes, it is the start of smoking turbo. if not, its either water vapor or gas.
 

·
Registered
Joined
·
177 Posts
Discussion Starter · #3 ·
Hmmmm...smells like a normal exhaust to me (well, seeing how i have the CPE downpipe with a cat...it's a lot stronger than stock). Can't really smell burning oil. Should I still be worried?
 

·
Registered
Joined
·
13,452 Posts
This morning, after driving my car a little har, I noticed blue smoke coming from my exhaust for about 20 seconds. I thought(HOPED) some oil may have gone through my catch can (since there is really nothing inside it to separate the inlet/outlet). I tapped the gas and it was gone. I drained the catch can (half full) and then let it idle about an hour and a half. Nothing coming out of the exhaust, other than water vapor. I ALSO have a Cp-e catted DP + more. Should I be worried?
 

·
Registered
Joined
·
156 Posts
I have a question about this subject....My car doesnt seem to smoke at idle but does during hard acceleration....Is this cause of oil getting into the intake, will a catch can solve this problem?
 

·
Registered
Joined
·
13,452 Posts
[quote author=08Mazdaspeed3 link=topic=135964.msg2956220#msg2956220 date=1235424370]
I have a question about this subject....My car doesnt seem to smoke at idle but does during hard acceleration....Is this cause of oil getting into the intake, will a catch can solve this problem?
[/quote]

All cars with a turbocharged engine smoke under heavy acceleration. This is normal.
 

·
Registered
Joined
·
13,452 Posts
[quote author=i love jdm hoes link=topic=135964.msg2929621#msg2929621 date=1234380240]
This morning, after driving my car a little har, I noticed blue smoke coming from my exhaust for about 20 seconds. I thought(HOPED) some oil may have gone through my catch can (since there is really nothing inside it to separate the inlet/outlet). I tapped the gas and it was gone. I drained the catch can (half full) and then let it idle about an hour and a half. Nothing coming out of the exhaust, other than water vapor. I ALSO have a Cp-e catted DP + more. Should I be worried?
[/quote]

Still nobody anwsered me.
 

·
Registered
Joined
·
156 Posts
How much is normal? and does the catch can help that?
 

·
Registered
Joined
·
145 Posts
My car only smokes when sitting idle for extended periods of time and it looks like blue smoke i hope its only turbo and not the heads, the stupid cobb ap was trying to push 20 psi of boost on stock dp and intercooler all other maps would not run at all barely was horrible, i think it damaged turbo ...
 

·
Registered
Joined
·
156 Posts
Yikes!
 

·
Registered
Joined
·
145 Posts
Ok so lets lay it out, after i get my car back from mazda with a new Turbo with my mods it will be pushing more CFM at the stock PSI,

I got the SU TMIC, su Boost tubes, cobb turbo inlet, cpe DP, borla catback, rear engine mount, (traction bars and tranny mount in mail), and Cobb AP

pretty much all the bolt ons except manifold, should i raise it to 16.5 PSI or leave totally stock, is there an advantage to having the cobb AP if all it can do for a tune is increase boost ... well shit i cant expect this to push 20 psi like the map calls for without ruining turbo again, with my mods it was prolly had WG always closed .. it really makes it look like it will force me to replace turbo so it can push 18 psi without failing....
 

·
Registered
Joined
·
78 Posts
i had the same problem , and my car is at 35k miles now.. i brought it to dealership, but they said they cant duplicate the issue, so i went to buy the extended warranty and not worried about it..

good news is the guy at the parts department is a member of austin mazdaspeed club
and he assured me that white smoke occasionally come out

and if just if something happened with turbo and engine, as long i didnt do anything to make the car faster (meaning change any internal parts and or turbo upgrade) warranty should cover everything

he has dp, cpe fmic, cpe engine mount, gauges, cai btw...
 

·
Registered
Joined
·
138 Posts
ok, so i had run into this same problem with my 07 speed and i was on the express way for like 30mins. or so then got off stopped at wendys and went through the drive through well needless to say i parked with the car at idle and about 5mins later my wife was like why is your car smoking like crazy, i look and i'm like shit there goes the turbo lol, i new right off the bat it smelled hella oil being burnt , but thats the first time it has done this that i have noticed, and it has 20,000miles on it. so yeah i recorded it and set up an app. with mazda....what do i do to get it to do it again so i can prove it besides my recorded clip......i have to drive 1hr to dealer on the expressway what should i do.......cause i'm not leaving without a new turbo.....and then do i need to take it easy for a break in period or no....? thanks all who reply.
 

·
Registered
Joined
·
693 Posts
[quote author=i love jdm hoes link=topic=135964.msg2929621#msg2929621 date=1234380240]
This morning, after driving my car a little har, I noticed blue smoke coming from my exhaust for about 20 seconds. I thought(HOPED) some oil may have gone through my catch can (since there is really nothing inside it to separate the inlet/outlet). I tapped the gas and it was gone. I drained the catch can (half full) and then let it idle about an hour and a half. Nothing coming out of the exhaust, other than water vapor. I ALSO have a Cp-e catted DP + more. Should I be worried?
[/quote]

from everything I've read about smoking turbo's, it doesn't just happen once and disappear, it stays until the turbo is changed out, i honestly cant tell you to be worried or not worried but if it were me i wouldn't worry to much until the thing doesn't stop smoking.
 

·
Registered
Joined
·
130 Posts
[quote author=duckduck link=topic=135964.msg2928557#msg2928557 date=1234331749]
let it sit in my garage in idle for 5-10 minutes. However, after 5-10 minutes, the faint white smoke is back. The smoke disappears by the time it rises to the roof-level of the car.

[/quote]
wow......i hope your door was up......or you might have taken a veeeerrrryyyyyy long nap....... :shock:
 

·
Registered
Joined
·
90 Posts
so i just finished installing my downpipe, and i noticed some blue smoke coming out of the exhaust. the car was idling in my driveway after i drove it around for a bit. the car was on a slight slope with the nose pointed down. (i didn't notice any smoke before with driving)
Is my seal gone,
or is it the pb blaster that i used on the bolts being burned off,
or due to the fact that the car was idling with the nose pointed down on the hill.
 

·
Registered
Joined
·
138 Posts
ok so here it is, when i turn off the s/c and t/c by holding the off button then starting the car and then driving it it causing the smoking issue, when i stop to go into a store and leave car idleing for like 5mins after doing so it smokes like its burning all of my oil its insane.....ok so i have concluded that it happens easier when using the hold down method of shutting off s/c and t/c before start up as to just pushing during car running method that you do get more boost, and that would be why i'm having this issue when driving with it like that much easier.......thanks all
 

·
Registered
Joined
·
693 Posts
[quote author=Stormin84 link=topic=135964.msg3009050#msg3009050 date=1237680509]
so i just finished installing my downpipe, and i noticed some blue smoke coming out of the exhaust. the car was idling in my driveway after i drove it around for a bit. the car was on a slight slope with the nose pointed down. (i didn't notice any smoke before with driving)
Is my seal gone,
or is it the pb blaster that i used on the bolts being burned off,
or due to the fact that the car was idling with the nose pointed down on the hill.
[/quote]

give it a couple days before any conclusions, are you running catted or catless?

MS3turbo, idk how turning the t/c off would cause smoking turbo.... sounds more like a coincidence than anything..... id test that a little more before i go with that theory.
 
1 - 20 of 31 Posts
Top