Mazda3 Forums banner
1 - 20 of 46 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter · #1 ·
Hey guys. Yes I searched this topic, but the threads that came up didn't go into solutions, so I'm asking...

My car has a rough idle, but only when the engine is warm. At start up, and while the engine is cold, it's fine. I replaced ALL the motor mounts and brackets last weekend, but the engine still bounces around. I noticed the tach is lower when the engine is shaky, so any ideas for as to the cause of this? I checked for TSB's about an erratic idle, but did not find any...

Any help/ideas are appreciated.

The car is an 05 with the 2.3l motor. Thanks.
 

·
Registered
Joined
·
157 Posts
I have the same problem with my '04 2.0 auto....will be taking it in to the dealer later this month to hopefully have them figure it out.
 

·
Registered
Joined
·
88 Posts
YOU ARE RUNNING LEAN --- PROBABLY FROM A:::

Vaccum leak!!!!

FIRST THING YOU DO:

Find your EGR VALVE --- TAKE THE PLUG OUT-- THIS DISABLES YOUR EGR

START YOUR CAR -- SEE IF IT WORKS

IF IT DOESN"T PLUG IT BACK IN ---

FIND YOUR PURGE VALVE AND FOLLOW IT DOWN TO YOUR INTAKE MANIFOLD --- YOULL SEE A RED CLIP -- TAKE IT OFF, REMOVE THE PLASTIC HOSE FROM THE INTAKE MANIFOLD-- COVER THE HOLE ON THE INTAKE MANIFOLD, AND HAVE SOMEONE START YOUR CAR---

IF THAT DOESN"T WORK----


PUT EVERYTHING BACK TOGETHER -- TAKE THROTTLE BODY CLEANER -- START YOUR CAR-- AND SPRAY IT AROUND YOUR INTAKE MANIFOLD, AND AROUND THE HOSES THAT ATTATCH TO IT--- IF IT STARTS TO IDLE BETTER -- YOU FOUND YOUR VACCUM LEAK


IF YOU CAN"T FIND YOUR LEAK--take it to mechanic and they will find it for u using a smoke test... GOOD LUCK!
 

·
Registered
Joined
·
27 Posts
I have a similar problem, but is more intermittent. Not throwing any codes, but sometimes after coming to a stoplight (engine warm) the RPMs gradually decrease and finally the ECU catches it before it stutters and brings the revs back to normal. It hasn't stalled on me yet, but the idle has dropped so low that all the lights on the dash have come on. It's extremely annoying, and my 05 is out of warranty now!
 

·
Registered
Joined
·
127 Posts
Hey guys, I agree this is very annoying when coming to a stop(erratic vibration), I've taken it to a dealer couple times and they have blamed it on my intake which is bullshit cause I notice it with my stock airbox, just curious on what milage you guys have? and if any maintainance has been done to your rides??

any feedback is really appreciated! thankz
 

·
Registered
Joined
·
533 Posts
[quote author=mrblob link=topic=107402.msg2215788#msg2215788 date=1207681223]
YOU ARE RUNNING LEAN --- PROBABLY FROM A:::

Vaccum leak!!!!

FIRST THING YOU DO:

Find your EGR VALVE --- TAKE THE PLUG OUT-- THIS DISABLES YOUR EGR

START YOUR CAR -- SEE IF IT WORKS

IF IT DOESN"T PLUG IT BACK IN ---

FIND YOUR PURGE VALVE AND FOLLOW IT DOWN TO YOUR INTAKE MANIFOLD --- YOULL SEE A RED CLIP -- TAKE IT OFF, REMOVE THE PLASTIC HOSE FROM THE INTAKE MANIFOLD-- COVER THE HOLE ON THE INTAKE MANIFOLD, AND HAVE SOMEONE START YOUR CAR---

IF THAT DOESN"T WORK----


PUT EVERYTHING BACK TOGETHER -- TAKE THROTTLE BODY CLEANER -- START YOUR CAR-- AND SPRAY IT AROUND YOUR INTAKE MANIFOLD, AND AROUND THE HOSES THAT ATTATCH TO IT--- IF IT STARTS TO IDLE BETTER -- YOU FOUND YOUR VACCUM LEAK


IF YOU CAN"T FIND YOUR LEAK--take it to mechanic and they will find it for u using a smoke test... GOOD LUCK!
[/quote]

Dude...a rough idle is not automatically caused by a vaccum leak. There are 100+ things that could cause a rough idle. Thanks for the CAPS LOCK TOO. ITS REALLY FUN READING MESSAGES WHERE EVERYTHING IS IN CAPITAL LETTERS. THE ONLY THING THAT WOULD MAKE IT MORE ANNOYING THAN CAPS LOCK WOULD BE BOLD AND CAPS LOCK AT THE SAME TIME. I ALSO THINK THE ONLY THING THAT WOULD BE MORE ANNOYING THAN BOLD AND CAPS TOGETHER WOULD BE A COMBINATION OF BOLD, ITALICS, AND ALL CAPS.[/ AND THIS IS CAPS LOCK WITH A TRIPLE THREAT. BOLD ITALICS AND UNDERLINED....ALL IN CAPS OF COURSE.
 

·
Registered
Joined
·
914 Posts
[quote author=Kodatech link=topic=107402.msg2286227#msg2286227 date=1209921920]
[quote author=mrblob link=topic=107402.msg2215788#msg2215788 date=1207681223]
YOU ARE RUNNING LEAN --- PROBABLY FROM A:::

Vaccum leak!!!!

FIRST THING YOU DO:

Find your EGR VALVE --- TAKE THE PLUG OUT-- THIS DISABLES YOUR EGR

START YOUR CAR -- SEE IF IT WORKS

IF IT DOESN"T PLUG IT BACK IN ---

FIND YOUR PURGE VALVE AND FOLLOW IT DOWN TO YOUR INTAKE MANIFOLD --- YOULL SEE A RED CLIP -- TAKE IT OFF, REMOVE THE PLASTIC HOSE FROM THE INTAKE MANIFOLD-- COVER THE HOLE ON THE INTAKE MANIFOLD, AND HAVE SOMEONE START YOUR CAR---

IF THAT DOESN"T WORK----


PUT EVERYTHING BACK TOGETHER -- TAKE THROTTLE BODY CLEANER -- START YOUR CAR-- AND SPRAY IT AROUND YOUR INTAKE MANIFOLD, AND AROUND THE HOSES THAT ATTATCH TO IT--- IF IT STARTS TO IDLE BETTER -- YOU FOUND YOUR VACCUM LEAK


IF YOU CAN"T FIND YOUR LEAK--take it to mechanic and they will find it for u using a smoke test... GOOD LUCK!
[/quote]

Dude...a rough idle is not automatically caused by a vaccum leak. There are 100+ things that could cause a rough idle. Thanks for the CAPS LOCK TOO. ITS REALLY FUN READING MESSAGES WHERE EVERYTHING IS IN CAPITAL LETTERS. THE ONLY THING THAT WOULD MAKE IT MORE ANNOYING THAN CAPS LOCK WOULD BE BOLD AND CAPS LOCK AT THE SAME TIME. I ALSO THINK THE ONLY THING THAT WOULD BE MORE ANNOYING THAN BOLD AND CAPS TOGETHER WOULD BE A COMBINATION OF BOLD, ITALICS, AND ALL CAPS.[/ AND THIS IS CAPS LOCK WITH A TRIPLE THREAT. BOLD ITALICS AND UNDERLINED....ALL IN CAPS OF COURSE.
[/quote]

I was thinking the same F'ing thing when I read this
 

·
Registered
Joined
·
10,739 Posts
[quote author=MrLiou168 link=topic=107402.msg2273811#msg2273811 date=1209505100]
I have a similar problem, but is more intermittent. Not throwing any codes, but sometimes after coming to a stoplight (engine warm) the RPMs gradually decrease and finally the ECU catches it before it stutters and brings the revs back to normal. It hasn't stalled on me yet, but the idle has dropped so low that all the lights on the dash have come on. It's extremely annoying, and my 05 is out of warranty now!
[/quote]

That happened to me too. Dealer will say you need a new MAF sensor, but you probably don't. Just clean your MAF sensor really well with the special cleaning spray designed for it, and it'll be good as new.
 

·
Registered
Joined
·
533 Posts
[quote author=Aura of Blue Hatch link=topic=107402.msg2289315#msg2289315 date=1210029232]
[quote author=Kodatech link=topic=107402.msg2286227#msg2286227 date=1209921920]
[quote author=mrblob link=topic=107402.msg2215788#msg2215788 date=1207681223]
YOU ARE RUNNING LEAN --- PROBABLY FROM A:::

Vaccum leak!!!!

FIRST THING YOU DO:

Find your EGR VALVE --- TAKE THE PLUG OUT-- THIS DISABLES YOUR EGR

START YOUR CAR -- SEE IF IT WORKS

IF IT DOESN"T PLUG IT BACK IN ---

FIND YOUR PURGE VALVE AND FOLLOW IT DOWN TO YOUR INTAKE MANIFOLD --- YOULL SEE A RED CLIP -- TAKE IT OFF, REMOVE THE PLASTIC HOSE FROM THE INTAKE MANIFOLD-- COVER THE HOLE ON THE INTAKE MANIFOLD, AND HAVE SOMEONE START YOUR CAR---

IF THAT DOESN"T WORK----


PUT EVERYTHING BACK TOGETHER -- TAKE THROTTLE BODY CLEANER -- START YOUR CAR-- AND SPRAY IT AROUND YOUR INTAKE MANIFOLD, AND AROUND THE HOSES THAT ATTATCH TO IT--- IF IT STARTS TO IDLE BETTER -- YOU FOUND YOUR VACCUM LEAK


IF YOU CAN"T FIND YOUR LEAK--take it to mechanic and they will find it for u using a smoke test... GOOD LUCK!
[/quote]

Dude...a rough idle is not automatically caused by a vaccum leak. There are 100+ things that could cause a rough idle. Thanks for the CAPS LOCK TOO. ITS REALLY FUN READING MESSAGES WHERE EVERYTHING IS IN CAPITAL LETTERS. THE ONLY THING THAT WOULD MAKE IT MORE ANNOYING THAN CAPS LOCK WOULD BE BOLD AND CAPS LOCK AT THE SAME TIME. I ALSO THINK THE ONLY THING THAT WOULD BE MORE ANNOYING THAN BOLD AND CAPS TOGETHER WOULD BE A COMBINATION OF BOLD, ITALICS, AND ALL CAPS.[/ AND THIS IS CAPS LOCK WITH A TRIPLE THREAT. BOLD ITALICS AND UNDERLINED....ALL IN CAPS OF COURSE.
[/quote]

I was thinking the same F'ing thing when I read this
[/quote]

Glad I'm not the only one. To the original poster...did you figure out your problem yet? There may also be a TSB for a re-flash....get the dealer to run your vin and check it out.
 

·
Registered
Joined
·
77 Posts
I have the same problem with my 05 2.3 auto. I notice that when at a stop with it in Drive the RPMs drop to almost 500. If I move it to Neutral or Park the shaking stops and the RPMs return to normal. I also suspect a vaccum leak. I haven't the foggiest idea where to begin to track it. I need to take it to the dealer and have them check it out. I have about 62k on it now, but did opt for the extended 100k warranty when I bought it. Does anyone know if something like that would be covered under an extended warranty?

Hopefully someone has an answer to this issue.
 

·
Registered
Joined
·
88 Posts
[quote author=Kodatech link=topic=107402.msg2286227#msg2286227 date=1209921920]
[quote author=mrblob link=topic=107402.msg2215788#msg2215788 date=1207681223]
YOU ARE RUNNING LEAN --- PROBABLY FROM A:::

Vaccum leak!!!!

FIRST THING YOU DO:

Find your EGR VALVE --- TAKE THE PLUG OUT-- THIS DISABLES YOUR EGR

START YOUR CAR -- SEE IF IT WORKS

IF IT DOESN"T PLUG IT BACK IN ---

FIND YOUR PURGE VALVE AND FOLLOW IT DOWN TO YOUR INTAKE MANIFOLD --- YOULL SEE A RED CLIP -- TAKE IT OFF, REMOVE THE PLASTIC HOSE FROM THE INTAKE MANIFOLD-- COVER THE HOLE ON THE INTAKE MANIFOLD, AND HAVE SOMEONE START YOUR CAR---

IF THAT DOESN"T WORK----


PUT EVERYTHING BACK TOGETHER -- TAKE THROTTLE BODY CLEANER -- START YOUR CAR-- AND SPRAY IT AROUND YOUR INTAKE MANIFOLD, AND AROUND THE HOSES THAT ATTATCH TO IT--- IF IT STARTS TO IDLE BETTER -- YOU FOUND YOUR VACCUM LEAK


IF YOU CAN"T FIND YOUR LEAK--take it to mechanic and they will find it for u using a smoke test... GOOD LUCK!
[/quote]

Dude...a rough idle is not automatically caused by a vaccum leak. There are 100+ things that could cause a rough idle. Thanks for the CAPS LOCK TOO. ITS REALLY FUN READING MESSAGES WHERE EVERYTHING IS IN CAPITAL LETTERS. THE ONLY THING THAT WOULD MAKE IT MORE ANNOYING THAN CAPS LOCK WOULD BE BOLD AND CAPS LOCK AT THE SAME TIME. I ALSO THINK THE ONLY THING THAT WOULD BE MORE ANNOYING THAN BOLD AND CAPS TOGETHER WOULD BE A COMBINATION OF BOLD, ITALICS, AND ALL CAPS.[/ AND THIS IS CAPS LOCK WITH A TRIPLE THREAT. BOLD ITALICS AND UNDERLINED....ALL IN CAPS OF COURSE.
[/quote]

I'm sorry that I offended you with my CAPS LOCKS -- I didn't know people got so annoyed with reading capital letters.

And I think i already mentioned the fact that it was PROBABLY a vaccum leak... I guess capital letters are not legible to the naked eye.

And most of the time rough idle is caused by a vaccum leak. Not only can the leak be caused by a cracked/frayed vaccum hose, but a valve that is stuck open including the purge valve and egr valve. Both of these issues are basically a vaccum leak. Not to mention that both of these issues are documented problems with mazda3's.

Rough idle is also usually due to a lean mixture, and you test it out easily by feeding the intake system with throttle body cleaner (which ritchens the mix). If it idles better you know that it is running lean. I actually sprayed it around the intake manifold and I ended up finding small holes in it. I replaced the entire manifold because of this.

I also had a problem with the EGR valve being stuck open, and when the engine was cold and started up, it was pretty good. As soon as it was warm, it would run much worse. So, this also coincided with the OP's issue.
 

·
Registered
Joined
·
42 Posts
I'll say it can be a EGR problem too. Have the EGR check and clean. Make sure is not stuck. :)
 

·
Registered
Joined
·
10,739 Posts
[quote author=rcbear link=topic=107402.msg2293228#msg2293228 date=1210129384]
I'll say it can be a EGR problem too. Have the EGR check and clean. Make sure is not stuck. :)
[/quote]

Is that the tube which circulates from the back of the engine back into the intake, just after the MAF sensor? I was cleaning my CAI filter a couple weeks ago, and noticed that the connector for that extra tube onto the intake piping had a film of oil on it, which I thought was weird, so I wiped it off... wondering if that's related.
 

·
Registered
Joined
·
88 Posts
No, that is the line going to the pcv valve. The film of oil is from your crank case ventilating.

The egr tube is located behind the intake manifold, you won't be able to see it from the top down. You can however access the valve solenoid, which is on the right side of the engine (6 wires goes into it).
 

·
Registered
Joined
·
72 Posts
Discussion Starter · #16 ·
Hey guys, the OP here. Many of the above mentioned things have been tried, and to no luck. The dealer has had the car for a week now, after returning it to them for the 3rd time for the same problem. They gave me a loaner and are being really cool about it (the car is out of warranty). They've even called Mazda corp. and talked to their techs and no one has a clue. They're continuing to work and guess at the problem (and they're not charging me for anything until it is fixed---like I said, they're being cool). I was told once the problem is resolved it will probably lead to a new TSB. Yay.

I'll let you guys know when I find out.
 

·
Registered
Joined
·
357 Posts
[quote author=MrLiou168 link=topic=107402.msg2273811#msg2273811 date=1209505100]
I have a similar problem, but is more intermittent. Not throwing any codes, but sometimes after coming to a stoplight (engine warm) the RPMs gradually decrease and finally the ECU catches it before it stutters and brings the revs back to normal. It hasn't stalled on me yet, but the idle has dropped so low that all the lights on the dash have come on. It's extremely annoying, and my 05 is out of warranty now!
[/quote]

This is identical to my problem. It's weird though cause it didn't start happening until I took out my Crankshaft Positioning sensor and then put it back in. (I had to replace it a few months back so I wanted to check it to see if this one was getting worn down like the other one did). Then all of a sudden now at idle my RPM's randomly drop down to almost stalling, and no CEL accompanying it. Grrrrr...
 
1 - 20 of 46 Posts
Top