Mazda3 Forums banner

41 - 42 of 42 Posts

·
Registered
Joined
·
2 Posts
I know this is old........but my 04 has been doing the exact same thing... it does throw a "Fuel Vacuum pressure" code, (Ill get the exact code details later today) that says something about "fumes" in there too, every so often.. thought it was my gas cap and just cleared out the code and went on with my life, But now, a couple years later, all the above is the exact thing happening to me to a T. ... will rev when i start it then slow down as it warms up... it will act like its gonna die when stopped (has died a couple of times), but will pick up a little when in park/neutral. We have tried the "relearn" the cleaning of everything.. and still does it... the only thing with my car, is it does have a crack/leak in the gas tank fill tube, as it will leak when I fill up my tank and dump all over the ground, right behind my tire... however, it had been doing that for since I got it 6 yrs ago all these other issues started about a year ago..., I just didnt overfill my tank... but now wondering if that is causing the "vacuum pressure" failure and this whole problem... after reading this thread, i am not hopeful that it will be though..
 

·
Registered
Joined
·
1 Posts
So do I have to pull battery cables before I do this or some relearn sequence like tap break pedal three times ECT... Or simply start car with no load and let it idle for 20min and with car still running switch a/c on and let it run for 20 more minutes and then what she's good to go or shut car off and restart
 
41 - 42 of 42 Posts
Top