Mazda3 Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Yes, the front right and the rear right running lights are not working. The bulbs are good and the brake works in the back but no running light. And HI, I just bought my 2004 Mazda 3 hatchback a couple days ago and I am trying to get all the kinks out. I have been wanting one for the longest but just didn't have the means, now I am ready to make it mine with some upgrades. But first things first...
 

·
Registered
Joined
·
9 Posts
Discussion Starter #2
Oh and the license plate light isn't working either, I found some wires coming from a rubber stopper that is located on the underside of the car at the very rear passenger corner. The wires had been stripped and not properly insulated so there was about two inches of bare wire that was touching and I fixed that with some butt connectors but still no luck.
 

·
Registered
Joined
·
872 Posts
Did you buy it from a dealer or private party, and does it have any sort of warranty? because it sounds like a decently serious electrical issue...
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
If push comes to shove, I am just gonna wire the right side off the left side on the front and back, but that is last resort. I just dont want to get pulled over driving at night.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #12
Nevermind, I got it. I cant believe there is actually a fuse for the right side running lights, apparently controls the license plate light also.
 

·
Registered
Joined
·
402 Posts
yeah there is one for the right side running lights that controls the license plate lisht and another fuse for the left that only controls the left, so u got it working, right?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #14
Yup, I have to admit though, when you said it was the fuse for the right side running lights, I thought you had no idea what you were talking about. But obviously I should be listening to the people that have experience with these cars, lol
 

·
Registered
Joined
·
2 Posts
Hi I have the same problem with the second gen mazda 3, I can not find the correct fuse, the right side parking and licence plate dont work, I already changed it but maybe is the fuse but I dont know which one is.

 
1 - 16 of 16 Posts
Top