Mazda3 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter #1
I pulled this from a post in another forum.. anyone else hear anything about this?

"Hi everyone,

Just got my first service done @ 4596KM. I got it done because of the CEL came on. No Mods yet on my Speed3 but the dealer told me that my car has a faulty EGR valve. They dont have the replacement part yet but it is safe to drive. They also told me that there will be a service recall for all Speed3's by next month. "
 

·
Registered
Joined
·
471 Posts
It's the cold weather CEL triggered by an emission valve getting stuck opened when it's cold

Same problem exists on MS6 and CX-7.

The fix will be here in feb.
 

·
Registered
Joined
·
5,723 Posts
i know a handful of people here have already had theirs replaced. not sure if it will be a recall or a general attention item for the techs to look at. I think when it goes bad you get a CEL, so at least so far, its not a universal problem.
 

·
Registered
Joined
·
471 Posts
well here in Canada, officials from Mazda Canada said that the fix wasn't here yet and it was being sorted out my Mazda HQ.

- They need to find a fix (probably done)
- Need to ship a copy to the gov for emissions testing and approval (because it's a valve on the emissions system)
- Need to ship to dealers
- Issue recall to owners

The good part is there are people on those forums that work for Mazda Canada (moderators) so we can ask em lots of questions and usually get satisfactory responses.

This is from one of the admins in the forum which is a Mazda Canada employee:

Hi!

I'm always available for info, and will not let anyone down...

I don't beleive the part refered to here is a modified part... Maybe a bad diagnosis, or the part ordered by the dealer is the same as the one on the car, thus it will have the same condition with the CEL...

Can BJC tell us which dealer he went to have the car and part checked?

You know, in Toronto, it's quite warm (10°C). It will take some time before we know if under cold weather, the problem is fixed.

For your info, we have the same issues with CX-7 and Mazdaspeed6, since they have the same engine. It is a priority for Mazda to fix this ASAP.

I'll advise once we have all the confirmed details and fixes.

Best regards,
According to what he says, even if you got your part changed, you probably still have a defective part (maybe not in the US, but in Canada yes as the fixed part isn't here yet).
 

·
Registered
Joined
·
133 Posts
I had mine replaced on Friday. And no, this is not the purge valve sensor; I already had that one replaced as well. When I was picking up my car (Grappone in Concord, NH) I saw another black MS3 going in for service. Anyone on here?

- alex
 

·
Registered
Joined
·
291 Posts
[quote author=alexio senchez link=topic=66747.msg1149592#msg1149592 date=1168818232]
I had mine replaced on Friday. And no, this is not the purge valve sensor; I already had that one replaced as well. When I was picking up my car (Grappone in Concord, NH) I saw another black MS3 going in for service. Anyone on here?

- alex
[/quote]

What is it then?? I just cleared mine...
 
1 - 8 of 8 Posts
Top