Mazda3 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi everybody,

I got a new MS6 (cherry black mica) a little more than two months ago and I already have problems. A couple of weeks ago, I was driving in dry weather and the traction control light went on for about 10 minutes and then was off. It wasn't flashing. It happened a second time, but I didn't think it was a problem. Few days later, the check engine light turned on, so I took the car to the dealer. The verdict, two problems: the intake runner switch and steering angle sensor were deffective. I love this car, but that's really disappointing!!!

Yesterday I even noticed that it's much noisier than usual. It has always been a little noisier than most cars I've driven, but now it's getting worse!

Anyone experienced similar problems or any other problem with MS6? And what do you guys think of the noise issue?

Thanks in advance
 

·
Registered
Joined
·
310 Posts
I've had mine a month, no problems so far. Maybe a bit disappointing to have sensors go bad, but at least there's a good system to let you know, and quick response to get them fixed. Hope you don't have anything else go wrong. As far as the (exhaust, I assume) noise level is concerned, a slight increase in level after the car breaks in is about right. I don't find it excessive, seems just right to me. Just be sure it's not caused by a leak.
 

·
Registered
Joined
·
310 Posts
...Update - At 2300 miles one morning the check engine light pops on, and is mostly on but intermittent. A trip to the dealer and they change a solenoid that the factory knows about and has supplied parts kits to rectify (service bulletin). I also notice after getting the car back that it's slightly louder than before, but by no means in a bad way. It's definitely got a more aggressive sound. I seem to be getting better mileage than before, too. I was barely squeaking 200 miles out of a tankful, this tank (my first since the repair) and it's looking more like my old 3 hatch used to get.

(Street racing bad...mmmkkkaaayyy----VRMS6)
 
G

·
Guest
Joined
·
0 Posts
Just picked up my Black Cherry sweetheart on Friday....I love this car so much. I haven't had AWD since my 1990 Talon and it's like becoming re-acquainted with an old friend. No spinning, no squealing, no drama...just lots of GO. I'm finding that a lot of smart-asses think they need to race me from stoplights, or on the highway. I can understand friendly competition, but not from Camrys and Jettas. It gets a bit more attention than I thought it would.

Anyway...hoping for no issues. It was a Mazda "executive demo' so I picked it up with 2063 miles on it, at a $6K+ discount off MSRP. I'm thrilled with it so far. Switching her over to synthetic oil this weekend.
 

·
Registered
Joined
·
5 Posts
Knock wood, My SmokeStone 6I is about 2 months old, I I have found wrong is a couple of scratches that the dealer put in it, and the tranny that was bucking a bit...
They re-programmed the tranny puters and all is well again...
BTW if you haven't already done so, get the CX& antenna mast... it looks great on the car
 
1 - 5 of 5 Posts
Top