Mazda3 Forums banner

1 - 20 of 23 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I just bought my mazdaspeed 3 about 4 weeks ago. I currently have about 1300 miles on it. Around 400 miles I noticed that the car starting losing overall power. I thought it may have just been the gas, but after quite a few tanks later it still doesn't run as good. I took my car back to the dealer and they told me that it is running fine. However, I disagree. When I first bought the car I could get on it in 2nd gear and spin the tires. It won't do that anymore. Sadly, I feel like my car now runs like a GTI. I am thinking that one of the clamps on the turbo inlet is loose or something. Another problem that I noticed is that the car doesn't shift as smoothly as it did the first couple weeks I had it. Does anyone have any ideas? Any feedback would be greatly appreciated.
 

·
Registered
Joined
·
6,480 Posts
check the oil, and also check for any vacum leaks
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
The oil is fine. I have not checked for vacuum leaks yet. But that will be the next thing I do. I hope I can get this problem fixed.
 

·
Registered
Joined
·
6,480 Posts
also.... try to change gas stations.. i strongly recommend BP... my friend had a similar power loss... when he used to use Shell or any other gas station.. I switched him over to BP.. and Huge difference was noticed..
make sure u use premium gas :)
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
I have switched gas stations a couple of times. I have even ran a little octane booster in my gas just in case it was the gas causing the problems. I will try BP though just cover all bases. What do you think the odds of a new car having a vacuum or a boost leak are?
 

·
Registered
Joined
·
6,480 Posts
[quote author=Midwestracer link=topic=140258.msg3023326#msg3023326 date=1238268532]
I would bet the crap oem bypass valve is leaking.
[/quote]
i could agree with that... i dont have a MS3 so its hard to tell for me....
i know my purge valve solenoid was garbage in MZ3... i mean still is.. g2 change that
 

·
Registered
Joined
·
16,466 Posts
could it be that while breaking it in you generally babied the car more and only went WOT for breif instances and rarely back to back constantly. perhaps now you are opening it up for more extended periods of time and really heating things up and just losing power from heat soak?

I know that I had a similar feeling of major loss of power the first time I really took the car out for a hard drive it just felt uninspiring after a while
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #10 ·
What replacement BOP or purge valve would you recommend. I really don't care about the noise either way. If it is leaking I just want something that will take care of the problem.
 

·
Registered
Joined
·
726 Posts
Here is my take : the Mazda Speed 3 ECU is very strange ... at times I feel like my car is running like a monster ... ie ... I upshift and BANG the exhaust pops out a gurggle pop and "wala" I take off like a rocket ship... other times depending on temp (above say 40 vs below 40 degrees) and relative humidity ... the car is very very sluggish ... in the morning during the winter / 22 degrees ... forget it ... in contrast this morning it was 47 and raining ... and I was running fast as heck ... since I removed both stock resonators I can somewhat sort of tell what I am dealing with when I hear the exaust ... a lot of pop and gurgle means fast ride. There are threads in history about how folks bought their cars, drove off the lot then at 1000 miles were disapointed - only to find that after 5000 miles the car was fast...???... I say allow more time to pass before getting the GTI...
 

·
Registered
Joined
·
12 Posts
I purchased a used MS3 08.5 about a week ago. Prior to that I had test driven one at a dealer. The used MS3 has now 6.3k Miles on... still brand new I would suspect. It is a CA car so it has the ULEVII emissions package :/

Up until 2 days ago the car has been great. Fun Fast and powerful. Two days ago I noticed what seemingly happened over night that I just seemed to lose power.

It is mostly noticed in 3rd gear and above since 1st and 2nd are limited and still might be in that power range. Before when I would punch the gas around 2.25k RPM in 3rd I would get the 'surge' of power at 3k-5k rpm.
But now its seems a much more gradual acceleration just a smooth increase no BOOM BOOM POWER.
The car is completely stock and i have no means of testing PSI. I live in Phoenix, AZ. Really dry here w/ temps around 60-80 right now. I really liked the car untill this happened and i am now a little worried.

Anyone have any ideas or tips on how I can look for any problems or issues?

on a side Note how much HP/TQ loss are casused from the CA emissions package.(That is not the problem the car seemed fine 2 days ago)

Boost leak possible I dont even know where to begin under the hood to look for such a thing. Please help. Thanks.
 

·
Registered
Joined
·
2,651 Posts
To much butt dynoing in this thread. If you drink more water one day than the next acceleration and braking will feel different due to variances in your inner ear, prove it on a dyno or it's all in your head.
 

·
Registered
Joined
·
2,651 Posts
I've got over 25k and never experienced it.
 

·
Registered
Joined
·
61 Posts
I was thinking this too, but looking at my dashhawk, I'm still getting 19psi spike down to 15-14psi, no leaks. I think you just get used to the power. Don't drive it for a week then get on it, it's still in there!
 

·
Registered
Joined
·
2,651 Posts
[quote author=uranium9v link=topic=140258.msg3033813#msg3033813 date=1238670476]
I was thinking this too, but looking at my dashhawk, I'm still getting 19psi spike down to 15-14psi, no leaks. I think you just get used to the power. Don't drive it for a week then get on it, it's still in there!
[/quote]

This is something I noticed. I'm taking somebody for a ride and push the car to impress them. I don't feel that it did that good then I look at them and they're in shock. You do get used to speed.
 

·
Registered
Joined
·
305 Posts
[quote author=Ryz link=topic=140258.msg3032126#msg3032126 date=1238613640]
I've got over 25k and never experienced it.
[/quote]

Drink more water!
 

·
Registered
Joined
·
2,651 Posts
[quote author=bravnik link=topic=140258.msg3034465#msg3034465 date=1238689966]
[quote author=Ryz link=topic=140258.msg3032126#msg3032126 date=1238613640]
I've got over 25k and never experienced it.
[/quote]
Drink more water!
[/quote]

Then I'd have to stop and hit the can more.
 
1 - 20 of 23 Posts
Top