Mazda3 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
294 Posts
Discussion Starter · #1 ·
so... when i turn on my parking lights, my right front and rear turn signals don't go on as well as my side blinker and my license plates lights.. but when i signal they work fine, except for the license plate lights.. they won't work at all.. i was wondering if this is a fuse problem and if anyone could hlep me out.. thanks!!

ron
 

·
Registered
Joined
·
294 Posts
Discussion Starter · #4 ·
[quote author=icspots link=topic=139971.msg3017326#msg3017326 date=1238021425]
Have you changed any of the bulbs? This sounds like what has happened to a couple of people who've done the full LED swap.
[/quote]

i changed the front n rear turns to leds but they were working fine for awhile.. license plate leds went out.. tried to mess wid em.. and now they wont turn on.. suggestions?
 

·
Registered
Joined
·
15,654 Posts
[quote author=rdazlex link=topic=139971.msg3017747#msg3017747 date=1238033393]
[quote author=icspots link=topic=139971.msg3017326#msg3017326 date=1238021425]
Have you changed any of the bulbs? This sounds like what has happened to a couple of people who've done the full LED swap.
[/quote]

i changed the front n rear turns to leds but they were working fine for awhile.. license plate leds went out.. tried to mess wid em.. and now they wont turn on.. suggestions?
[/quote]

Yeah, I believe it's always the LED license plate that causes problems. Try swapping it for the original bulb and see what happens.
 

·
Registered
Joined
·
25,357 Posts
What LED's do you have in your car?

I have had LED's in the license plate lights of both of my 3's and never had any problems with any of them, both different brands too.
 

·
Registered
Joined
·
15,654 Posts
[quote author=smokinAMD link=topic=139971.msg3018093#msg3018093 date=1238043605]

I have had LED's in the license plate lights of both of my 3's and never had any problems with any of them, both different brands too.
[/quote]

I'm not saying it's all LED license plate lights, however after swapping to LEDs several members have had problem once they installed that light. Whether it was the light itself, incorrect installation, solar flare, land shark I don't know.
 

·
Registered
Joined
·
294 Posts
Discussion Starter · #8 ·
thanks for all the input guys... to just trace back my steps.. i swapped out my stock license plate lights for 6 wedge leds and they worked fine... decided to put those in my domes and buy 12 wedge leds for the license plates and they started flickering ever since i installed em.. decided to see what was wrong.. turns out a blew a fuse messin with them.. replaced the fuse and put in my original bulbs for the license plate lights and now they all work fine.. got all my bulbs from superbrightleds and still am in the hunt for leds for my license plate.. thinkin bout goin back to the 6 wedge leds from superbrightleds.. anyone have a better idea on where to get more stable ones? thanks
 
1 - 8 of 8 Posts
Top