Mazda3 Forums banner
1 - 9 of 9 Posts

· Registered
Joined
·
114 Posts
Discussion Starter · #1 ·
My 04 hatch is experiencing some knocking when I start the car cold and it's coming from the passenger side. It also happens sometimes when going into 1st gear. I'm assuming it may be the mount since it feels like there is wheel hop but I'm not too sure since I've never experienced wheel hop before.

Im also guessing it may be my mout because my car was in the shop for 8 weeks and when I got it back there was no vibration or knocking. Also when going into first there was no rattling. but after driving it for a bit the knocking at 1st came back. so I'm assuming the mount seized up and hardened over that 8 week period.

Aside from the knocking, when I got it back it forgot all my cel so my idle was acting it. It was almost about to stall but when the AC is on it will stall more frequently. After the car learned the codes the idle became normal.

cel P0850 & P0507

so anyways could you guys give me some insight? Thanks in advance.
 

· Registered
Joined
·
14,062 Posts
Mount goes bad on every single one of these cars so it's 100% normal (particularly in the 50-70k range).

Replace it either with stock or aftermarket, very easy to replace it yourself (many tutorials around). Downside with aftermarket is it will greatly introduce a LOT of vibrations into the cabin the stock one does not (even the softest of the soft of aftermarket is still considerably more harsh than stock).

As far as that 0507 code, as listed it could be a busted PCV or other vacuum leak. Definitely take a look around see if you see any cut hoses or damaged hoses or otherwise take it to your mechanic.
Without being to mechanically inclined, replacing the PCV (specifically alone) isn't something you'd want to tackle, especially the stock intake manifold, it just isn't much fun. Otherwise if you are and have a friend willing to help (someone with small hands is a plus!) then by all means.

But definitely want to get that fixed, if you've been running that code for that long, it isn't at all good for your engine because it's forcing the engine to run hot, which as you should know, an overheated engine is not good at all.
 

· Registered
Joined
·
114 Posts
Discussion Starter · #4 ·
So as far as the motor mount concerns what are a good brand and a decent amount if duro for daily driving. my plans for my 3 is show car not a track car. but I like drive spiritedly every so often.

an could there be other cause to that pcv code? if not ill try and grab some buddies to replace it. my car has been stalling untill it learned the code.
 

· Registered
Joined
·
14,062 Posts
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top