Mazda3 Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Gosh if any one could be Of any help I would be sooo greatful. For a few years now when I start my 2007 Mazda 3 2.3L on a cold morning it will idle extremely low, almost to a stall, I have to push the gas pedal down just a little bit to raise the idle and almost immediately the car will idle high on its own and begin to warm up. It started out doing this very infrequently, now it seems to be doing it every other morning. Recently my car popped the code P2405 (Description: Evaporative emission (EVAP) pressure pump - mechanical fault, Cause: EVAP pressure pump orifice missing), I have reason to believe that this code is related to my car having trouble starting because every time I clear the code it reappears only after my car has trouble starting, which at this point seems to be every few days. I have replaced my EVAP purge valve hose, I also replaced my gas cap exactly 1 year ago, so I don’t think it’s either of those. Though I might try replacing my gas cap again today. I connected a small hose where the EVAP purge valve hoes goes and ran Seafoam through to see if I could clear out any junk that might be throwing the code. Has any one had any luck detecting what causes the P2405 code?
 

·
Registered
Joined
·
4 Posts
Hello, I have 2006 M3 2.3L with the same p2405 code repeating. Your post is many years ago but thought I asked what did you do to fix the issue ?? Code p2405 is specific to the EVAP Leak Detection Pump (LDP) mounting on rear crossmember above rear passenger wheel and very difficult to change without a car lift. Thank you in advance!
 
1 - 2 of 2 Posts
Top