Mazda3 Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I have a 2006 Mazda 3S hatchback with 192,000 miles that is throwing a p0011 ("A" Camshaft Position - Timing Over-Advanced or System Performance (Bank 1)) and p0016 (Crank/Cam Position Correlation – Bank 1 Sensor “A”)

Also threw a p0138 (O2 Sensor Circuit High Voltage (Bank 1, Sensor 2) previously but hasn't come back.

I noticed the CEL then the car developed a rough idle later in the day. It died while at a stopsign on the way home and wouldn't stay running until the 3rd restart. Then died as soon as I got into the driveway as I stopped in the driveway. It also developed a loud dragging sound about halfway through the drive as if the calipers were sticking. At first it was fairly quiet but became much louder as the drive went on and after the car stalled and was restarted. The noise only occurred while driving.

What steps should I take to diagnose this? What parts should I order? I checked the oil and while low, it was registering on the dipstick just around the min line. The car does burn oil and is often what appears to be significantly low (down 1+ quarts when checked after a few weeks or changed).

Are these threads relevant?: http://www.mazdaspeedforums.org/forum/f293/strange-p0011-cell-200992/


http://www.mazdaspeedforums.org/forum/f10/replacing-timing-chain-71935/

Thank you
 

·
Registered
Joined
·
291 Posts
Based on everything you wrote, I recommend a compression test before doing anything else.
 
1 - 2 of 2 Posts
Top