Mazda3 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Recently bought a 2008 Mazda 3i (auto) with around 100K miles from a local Mazda dealer. For the most part, it's been decent but seeing little issues showing up here and there and need some advice how to deal with them:

1) Occasionally feels like it wants to stall out right after a restart. Not all the time but enough to be annoying. I also find that when I fill the car with gas, it'll do the same thing--run like crap for a few seconds then settle out.

2) Tach has a tendency to wander around a 250 rpm range (500-750 or so) whenever the car is coasting without touching the accelerator. Seems to occur below 30 MPH and I've seen it happen in both 3rd along with 4th gear. Doesn't happen in 2nd, no wandering RPM when you're on the gas and idling at a stop is fine.

3) Is there a limit to where long fuel trim becomes concerning? Seems to run in the +5 to +11 range under most conditions (short trim usually is between -3 and +3)
 

·
Registered
Joined
·
1,032 Posts
Do the simple things first: take a can of Gumout and clean the throttle body. With 100,000 miles, I'll bet there's all kinds of black carbon built up in there.

It's easy
1. take the rubber hose off of the throttle body
2. spray the ever living crap out of the throttle body, and be sure to open the butterfly to get all around in there
3. replace the rubber hose
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
Still having a hard time getting used to the accelerator being an input and not an actual 'control'. That and the manual mode being backward (forward=down, back=up) from conventional logic
 

·
Registered
Joined
·
2,282 Posts
Believe it or not, that shift setup is proper for a racing sequential. Follow the linear g forces: pull the shifter while accessing, push while braking.

Sent from my SAMSUNG-SM-G891A using Tapatalk
 

·
Registered
Joined
·
15 Posts
Discussion Starter #7 (Edited)
Cleaned the MAF and throttle body, both didn't really seem that dirty. Also changed the purge valve as those are known faily things (and I got one cheap enough). It *seems* less bullshitty at low speeds now, gonna have to wait till it full learns to see if it stays that way or it relearns its bad habits again.

EDIT: filled the car up and no restart nonsense. Knock wood.
 
1 - 7 of 7 Posts
Top