Mazda3 Forums banner
21 - 32 of 32 Posts

· Registered
Joined
·
138 Posts
does this happen about 2500 rpm in 3rd gear or higher?

i was just cusing normally in a higher gear and it happened to me aobut 5 times...very very lightly accelerating when it's real cold out 10-25 degrees then the car gives an abrubt hiccup in acceleration. no engine light. no other problems
 

· Registered
Joined
·
65 Posts
Discussion Starter · #22 ·
[quote author=k4hscorpion link=topic=69049.msg1197491#msg1197491 date=1171047710]
Shouldn't you be shifting down to 5th gear if your only going 65 mph and plan on going WOT?
[/quote]

Nope. Why do you think we got these cars anyhow?
 

· Registered
Joined
·
6,077 Posts
I brought my car in complaining of this problem, and also had the CEL on for code P2006. The problem was, "IMRC switch was not contacting IMRC valve actuator lever." They made the modification and we will see if that fixed it. The reason I'm righting this here is that there is a good chance that this issues is being caused by this, and all 3's are having trouble with this and the purge valve.
 

· Registered
Joined
·
2,087 Posts
[quote author=solipsism link=topic=69049.msg1197073#msg1197073 date=1171037348]
Coming home from work this morning I was 'testing' my car against my buddies 06 Eclipse GT. I had done this once before previously with the same conditions (-35C slightly slipperly roads, no spin, DSC on). Both our cars had been warmed up for the same amount of time and driving.

Previously it was pretty even, i was faster in the lower gears, and rolling from lower speeds, he was slightly faster in the midrange and i was overall had a higher top speed.

This time however, from mid, mid-lo and highspeed starts my car wouldnt budge and he smoked me every time. My car was awesome on the drive to work today, but not so on the way home.

Me thinks im getting the xede to combat this problem. I will probalby get the AP too if it comes out in a timely fashion. I will probably only have this car for 2.5 more years. So waiting for a year for the AP is a waste of time (33% of my time with this car).
[/quote]

I'm seeing 14.9 for the 06 eclipse. You should easily smoke your friend even from a roll. If you were even, it simply means you haven't truly learned the powerband of the ms3 yet or there's something wrong with your car. Keep the rpms between 3-5k and you should be fine. And dsc should be OFF (if the roads are slippery even a little, don't race!).The xede will help but it will do little good against a better driver.


On topic:

I took a long drive this past weekend and had really put her to the test on the highway from a roll and had not noticed this powerloss, unless the poster is simply talking about turbo lag which is normal. I did a couple 6th-5th pulls (to about 125 briefly) and my friend couldn't believe the power the car had in the higher gears. He certainly respected it a lot more after that drive. I've also learned that we may have an adaptive ECU. I've noticed that if I drive the car hard, keeping the rpms in the powerband, boost comes on sooner and stronger for a while after until I start driving like grandma again. I'm not 100% sure on that but I've been able to reproduce it over and over. No big deal, just something to ponder.
 

· Registered
Joined
·
234 Posts
[quote author=Betelgeuse link=topic=69049.msg1198607#msg1198607 date=1171077225]
[quote author=solipsism link=topic=69049.msg1197073#msg1197073 date=1171037348]
Coming home from work this morning I was 'testing' my car against my buddies 06 Eclipse GT. I had done this once before previously with the same conditions (-35C slightly slipperly roads, no spin, DSC on). Both our cars had been warmed up for the same amount of time and driving.

Previously it was pretty even, i was faster in the lower gears, and rolling from lower speeds, he was slightly faster in the midrange and i was overall had a higher top speed.

This time however, from mid, mid-lo and highspeed starts my car wouldnt budge and he smoked me every time. My car was awesome on the drive to work today, but not so on the way home.

Me thinks im getting the xede to combat this problem. I will probalby get the AP too if it comes out in a timely fashion. I will probably only have this car for 2.5 more years. So waiting for a year for the AP is a waste of time (33% of my time with this car).
[/quote]

I'm seeing 14.9 for the 06 eclipse. You should easily smoke your friend even from a roll. If you were even, it simply means you haven't truly learned the powerband of the ms3 yet or there's something wrong with your car. Keep the rpms between 3-5k and you should be fine. And dsc should be OFF (if the roads are slippery even a little, don't race!).The xede will help but it will do little good against a better driver.


As I said before we were even with me beating him by a little, but him having more pull in the higher rpm band. He says his power band goes from 4k-redline with the MiVec system (sp). So what Im saying is yesterday I didnt have the same amount of pull as I should have.

Starting from a roll like we were doing at an already high speed I had no choice but to start at around 4000rpm in 4th. Which on his car is pretty much the begining of his power band. Btw he has the 6speed. I was shifting a little bit later as my clutch was still cold. But yeah he is a more experienced driver than I. but this doesnt explain that I was pulling harder before as opposed to me. I did have the dsc on though.

We are waiting for summer before doing anything more.

I know the Xede obvioulsy wont help with driving skills, but this just makes me want to get it even more. Fact is, I will wait until some maps are available for the exhaust and intake mods. This is what makes the C-PE solution appealing.

Anyway, sorry for offtopic, wont threadjack anymore.

I also still have a Check engine light.
 

· Registered
Joined
·
2,823 Posts
That sucks on the CEL. For those of us that have had the problem (mine's done it twice now, 2nd time wasn't as "abrupt") How rich is your car running? Seriously I bought this thing three weeks ago, and my tailpipe is COVERED in carbon. I'm wondering if that has something to do with it. A poorly tuned fuel system could cause a glitch that would make the car go pig rich and bog. Which would feel identical to what a lot of us are experiencing.
 

· Registered
Joined
·
1,752 Posts
[quote author=Betelgeuse link=topic=69049.msg1198607#msg1198607 date=1171077225]
[quote author=solipsism link=topic=69049.msg1197073#msg1197073 date=1171037348]
Coming home from work this morning I was 'testing' my car against my buddies 06 Eclipse GT. I had done this once before previously with the same conditions (-35C slightly slipperly roads, no spin, DSC on). Both our cars had been warmed up for the same amount of time and driving.

Previously it was pretty even, i was faster in the lower gears, and rolling from lower speeds, he was slightly faster in the midrange and i was overall had a higher top speed.

This time however, from mid, mid-lo and highspeed starts my car wouldnt budge and he smoked me every time. My car was awesome on the drive to work today, but not so on the way home.

Me thinks im getting the xede to combat this problem. I will probalby get the AP too if it comes out in a timely fashion. I will probably only have this car for 2.5 more years. So waiting for a year for the AP is a waste of time (33% of my time with this car).
[/quote]

I'm seeing 14.9 for the 06 eclipse. You should easily smoke your friend even from a roll. If you were even, it simply means you haven't truly learned the powerband of the ms3 yet or there's something wrong with your car. Keep the rpms between 3-5k and you should be fine. And dsc should be OFF (if the roads are slippery even a little, don't race!).The xede will help but it will do little good against a better driver.


On topic:

I took a long drive this past weekend and had really put her to the test on the highway from a roll and had not noticed this powerloss, unless the poster is simply talking about turbo lag which is normal. I did a couple 6th-5th pulls (to about 125 briefly) and my friend couldn't believe the power the car had in the higher gears. He certainly respected it a lot more after that drive. I've also learned that we may have an adaptive ECU. I've noticed that if I drive the car hard, keeping the rpms in the powerband, boost comes on sooner and stronger for a while after until I start driving like grandma again. I'm not 100% sure on that but I've been able to reproduce it over and over. No big deal, just something to ponder.
[/quote]

my 93 probe GT had an adaptive ecu as well as my contour svt...both older cars, I think many cars have this, so it would not surprise me if the speed3 did. it will adjust to the driving habits of a vehicle. another reason why having many drivers on one car is not good.
 

· Registered
Joined
·
245 Posts
Mine will also do it in 5th from a cruising rpm roll on. Power, stumble, power. I'm sure they all do it, and it's normal. If I go through all of the gears under boost I don't get any lag, just when rolling on in a higher gear.
 

· Registered
Joined
·
65 Posts
Discussion Starter · #31 ·
[quote author=TrueRedSpeed link=topic=69049.msg1198583#msg1198583 date=1171076659]
I brought my car in complaining of this problem, and also had the CEL on for code P2006. The problem was, "IMRC switch was not contacting IMRC valve actuator lever." They made the modification and we will see if that fixed it. The reason I'm righting this here is that there is a good chance that this issues is being caused by this, and all 3's are having trouble with this and the purge valve.
[/quote]

I had the CEL and got the valve fixed before having this issue with the power loss.
 

· Registered
Joined
·
2,823 Posts
So I brought in my car to the dealer yesterday. They said they couldn't replicate the problem (Of course not. They had some midget tech driving my car too. I was totally crotching that steering wheel when I got back in). However, they did reflash my PCM, and the car does seem to be running better. If it's a permanent thing, who knows. Chances are it'll never get cold enough to replicate the conditions it happened in either time.
 
21 - 32 of 32 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top