Mazda3 Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
632 Posts
Discussion Starter · #1 ·
bought some for my fogs. H11 is what i ordered. I assume they're the same, but they won't clip into the factory harness? wrong product or do i need to purchase and additional harness?
 

·
Registered
Joined
·
2,127 Posts
hmm yeah i just checked the bulb number thread and it should be h11 for an 05.

are you sure the bulbs you received are actually h11? it should be stamped on the socket somewhere...
 

·
Registered
Joined
·
12,744 Posts
i had a slight problem trying to get mine in the h11 factory harness. make sure you try then in every slot, i looked through the front of the housing to make sure i was getting the bulb in the harness correctly. :)
 

·
Registered
Joined
·
632 Posts
Discussion Starter · #4 ·
just realized. i ordered H11, got 880's. since they're open they can't be returned......great.
 

·
Registered
Joined
·
12,744 Posts
[quote author=slowmz3 link=topic=134373.msg2889503#msg2889503 date=1232916108]
just realized. i ordered H11, got 880's. since they're open they can't be returned......great.
[/quote]

you need to call where you ordered them. they screwed up. you did not.
 

·
Registered
Joined
·
372 Posts
I had some luminics back in the day and they let me return them after i opened them. Just explain to them what happened and that you didnt realize the size was different and they should do an exchange for you.
 

·
Registered
Joined
·
2,127 Posts
yeah they have to fix your order regardless of whether or not you opened them...

after all they didn't send you what you paid for..
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top