Mazda3 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
New member, looking for some input

We have a 07 mazda 3. Heres the story

My son was driving and ran over a traffic cone. Immediately the oil and battery lights came on. He stopped for a second, then started car back up amd drove 5 min. At that point the car shuts down apparently. Aaa tows him home

Cone took out the oil filter and broke the mount. I reolaced them today. Added oil . Car cranks but sounds weird and wont start.

I shot a short video of it cranking.

Anyd idea what might have happened? Obviously driving 5 min wasnt good. Im trying to determine if the car is done or its something i may be able to fix.

Thanks for any advice
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
I guess I'm wondering if anyone might know what may be wrong based upon the video. Doesn't sound right cranking but thought maybe it could be fuzzed. It's not grinding so thought maybe it's not catastrophic
 

·
Registered
04 Mazda 3 HB
Joined
·
6 Posts
I guess I'm wondering if anyone might know what may be wrong based upon the video. Doesn't sound right cranking but thought maybe it could be fuzzed. It's not grinding so thought maybe it's not catastrophic
Are you throwing any codes? CEL on? I would be curious and see if I could manually turn the engine over. Starter sounds like it is turning it over though.

Reading it again, you mention lights are on.. I would also try to pull those codes and see what the car is telling you.
 

·
Registered
Joined
·
14 Posts
You should have it checked by a mechanic to find out what's wrong since there are several factors to determine if an engine is about to die.
 
1 - 6 of 6 Posts
Top