Mazda3 Forums banner

1 - 20 of 22 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Ok everyone, by now those of you who own a 2004 Mazda 3-2.3, know about the intake manifold issues with sticking and the notorious clicking annoying sound especially when the engine is cold. I had the intake manifold replaced with a new one from a Mazda dealer and unfortunately, the problem came back (wtf). With this said, can anyone tell me, out of experience, how you took care of that problem, how you got it fixed. I've seen a lot of videos of people seafoam their engines but I want to know from those who have done it, if seafoaming the engine fixed the sticking and clicking sound problem in the intake manifold permanently.
 

·
Registered
Joined
·
51 Posts
I've recently been experiencing this as well as a rough idle. Threw a lean code the other night and a technician friend of mine found a leak near the first injector on the left where the intake manifold meets the engine. We replaced that gasket 4-5 months ago, i'm guessing it didn't seat properly. He sprayed some type of liquid ( i think starting fluid) to find the leak and the engine definitely changed idle (assuming starting fluid would cause it to choke a little) and the gasket seemed to swell or seat better (and definitely improve idle/performance). My idle has gotten a little rougher again so i'm thinking of replacing the gasket again or seeing what else I can find. Not sure if this helps, but I would check for a vacuum leak around the manifold as well.

Hopefully someone better experienced can help us with this.

Thanks!
 

·
Moderator of donks
Joined
·
32,022 Posts
[quote author=em3s link=topic=204635.msg4195200#msg4195200 date=1330959526]
If that's your best answer, don't waste my time.
[/quote]

A little explanation goes a long way. This is far from an issue that "everyone knows about". Fuel injectors make a clicking sound in normal operation, so from what you said, everyone with a 3 must have this issue.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #6 ·
I did that before and found that injector 1 had the rubber seal broken so I replaced it. After that I checked again for vacuum leaks and all was fine. It has to be some other problem.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #7 ·
I never said anything about the noise coming from the injectors. There is some kind of valve in the intake that sticks and makes a nasty loud clicking sound. This is common in the 3s. And yes, a lot of people have experienced this issue with their cars. There are a lot of posts about this issue in other forums out there. I've done some research but no luck fixing the problem. That is why I'm asking here. There's even a Youtube video out there.
 

·
Registered
Joined
·
128 Posts
 

·
Registered
Joined
·
354 Posts
[quote author=em3s link=topic=204635.msg4195216#msg4195216 date=1330960588]
There is some kind of valve in the intake that sticks and makes a nasty loud clicking sound.
[/quote]

What kind of valve would that be? Is it a fast tick? A slow tick? How many ticks per minute would you say?
 

·
Registered
Joined
·
128 Posts
The only "valves" inside the intake are the VTCS right?
 

·
Registered
Joined
·
354 Posts
Ah that's my bad, my brain translated "when cold" to idling lol. I actually didn't know our intake manifolds had the variable length system, that's pretty cool.
 

·
Registered
Joined
·
769 Posts
I removed my VTCS and still have the sound. Must be the VIS. It goes away when the electric connector is unplugged.
 
1 - 20 of 22 Posts
Top