Mazda3 Forums banner
1 - 20 of 154 Posts

·
Moderate your face
Joined
·
6,577 Posts
Discussion Starter · #1 ·
To keep down on the opening of topics for thermostat replacement and CELs related to the thermostat, here is a central how-to location. Below is the best how-to I've seen written (and the one I followed). It doesn't have pictures but if someone has some I'll insert them and assign credit like I did with this how-to by MZ3MadMax:

Before following this how-to, the thermostat you should buy should come from the dealer and be OEM. It's around $50-60. Link to part number. Verify with a dealer that the part number is correct for your vehicle. Reference purpose only. There are many documented cases of aftermarket thermostats failing fairly quickly. I can verify this as it happened to my self.

[quote author=MZ3MadMax link=topic=120362.msg3625491#msg3625491 date=1271796877]
You don't need to cut the AC Belt to do the thermostat. You only have to cut the AC Belt if you want to replace the serpentine belt - a whole different topic. You only need to take the serpentine belt loose to do this job. Some have claimed to have replaced the thermostat without removing the belt or the tensioner. I suppose that it is possible but I can't imagine that it would be easier.

The following (from memory) is a quick summary of the job on a 2.3L:

A) Tools - Metric socket set with 1/2" and 3/8" drives. A couple of extensions and/or deep sockets are helpful. a pair of pliers for the hose clamps

B) Supplies - replacement thermostat, 2 gal of pre-mix 50/50 coolant. I only used 1 gal but I used all of it...


1) Prep - put the car up on ramps or jack stands so you can easily get under the vehicle. Remove the plastic shield/cover under the motor. Remove the plastic cover on the top of the motor. Let the car cool off enough so that you don't get burned by the hot coolant.

2) Drain the radiator coolant. There is a Walk-Thru in the Maintenance section on Drain and Fill Coolant and hose replacement - same procedure. Remove the cap on the reservoir. Remove the plug (1/4 turn counter-clockwise and pull straight out) at the bottom and back of the radiator on the drivers side. Fluid will shoot out about 3 feet directly into the transmission and splash everywhere if you don't get a bucket in place to catch it so be ready. Once it is drained, replace the plug and make sure that it is all the way in and turned clockwise to lock.

3) Remove the serpentine belt from the tensioner. The tensioner is a silver device with a pulley on the top front passenger side of the motor. Take a socket on a ratchet and attach to the "bolt" on the passenger side of the tensioner and push toward the rear of the car to loosen the belt (maybe toward the front, I can't remember. This should be obvious though to loosen the belt.). While holding the tensioner, slide the belt over and off of the pulley. Try to be careful not to let the belt come off the other pulleys. If it does, no big deal, just pay attention so it can be routed properly later.

4) Remove the tensioner from the motor. I believe that there were 3 (maybe 4) bolts to remove from the front and it comes right off. The thermostat should be out in the open now as it is located just below the tensioner on the front of the motor. It is pictured above in this thread and has two rubber hoses connected to it.

5) Remove the two hoses from the thermostat. The hose clamps can be loosened by grasping them with pliers on the tabs. This will loosen the clamps and allow them to be slid further down the hose a couple of inches in order to clear the flanges on the thermostat. The hoses can now be coaxed off of the thermostat hose flanges. You may have to work them a bit to get them off but it should not be too difficult. More fluid will drain from the hoses so be ready for that. Move the hose ends out of the way as much as possible.

6) Remove the thermostat. This is three bolts on the front. The thermostat should come off quite easily and leave no gasket or residue. Again, some coolant may come out but not too much.

The rest is pretty much a reversal of the process:

7) Install the new thermostat. Check to make sure that the mounting face on the motor is clean - I would wipe it off with a paper towel. Make sure that the flat rubber gasket is located in the groove on the face of the mounting flange of the new part. The new part should come with the gasket pre-installed. Just put the new part in place and insert the bolts. The plastic mounting flange has steel inserts in the bolt holes so it wont crack. Snug them down pretty tight - I don't know what the torque spec is but I made them reasonably tight.

8) Re-connect the hoses. Some folks like to replace the spring hose clamps with "real" hose clamps that use a screw to tighten. Feel free to do so if you want - I didn't and have had no issue with leaks. If you do, be sure to put them on the hoses before you put the hoses on the thermostat. This seems obvious but I've done this wrong many times. No big deal, you just have to remove the hoses again... Put the hoses on and move the clamps back into position and tighten.

9) Re-install the belt tensioner. Put in place and insert the bolts. Again, make them snug but not over tight since you are threading them into aluminum.

10) Re-install the serpentine belt. Use the ratchet as before to move the tensioner pulley into place and slip the belt over the pulley. You will have to put the socket/ratchet through the belt before you move the tensioner, otherwise you will not be able to get the belt in place - you'll see what I mean. This can be a little trickey, just pay attention to the routing of the belt on the other pulleys and make sure that it is in the correct place. This is the only step where it might help to have another set of hands to hold the ratchet/tensioner while you move the belt around. There is a diagram/sticker nearby that shows the belt routing if it slips off too many places.

11) Replace the plastic shield/cover under the motor and the plastic cover on the top.

12) Fill the coolant reservoir. With a funnel, as you add coolant to the white container on the passengers side, it should begin to flow into the radiator - slowly. Put as much in (up to 1 gallon) as you can. When it stops taking any more, it is safe to start the engine. You might double-check the belt to make sure that it is installed properly before starting. Also, make sure that no one is standing over the engine when it is started just in case it throws the belt.

13) You can back the car off the ramps or remove the jack stands. As the car warms up, it will extract more coolant out of the reservoir. You may have to slowly add more coolant to the container as the engine warms up. After about 5 minutes if the motor is up to operating temp, you can top off the level to the "Max" mark. Drive the car around for another 5 minutes or so and then let it cool off completely. When totally cooled off, check the coolant level and fill to the "Min" mark. Check it again a a couple of days and make sure that it is at the "Min" mark when cool.

Congratulations, you're done.

It is harder to write all of that than to actually do it...
[/quote]

[quote author=codyds link=topic=202138.msg4193185#msg4193185 date=1330473303]
Here are some pictures, since they are few and far between.




















That is where the pictures end, as my hands got too coated with coolant to pick up the camera again. But it is self explanatory from there!
[/quote]
 

·
Registered
Joined
·
1 Posts
I did it! I replace the thermostat and here is my two cents: the clamps were a bit of a challenge ,those clamps have a little notch that if you press them just right (I used a small channel lock-just the tip) and then you turn it, the clamp will stay lock in the open position. there must be a special tool for it. Also, if you are not draining the antifreeze, make sure you use lots of plastic to cover the alternator... at first when I took out the thermostat there was just a small amount of antifreeze, but later (it seems that a vacuum is formed) about 3 liters of antifreeze came out. I hope this helps. Good luck
 

·
Registered
Joined
·
381 Posts

·
Moderate your face
Joined
·
6,577 Posts
Discussion Starter · #4 ·
[quote author=Silver3i link=topic=202138.msg4171019#msg4171019 date=1326138890]
omg.. thank you.. i just got this cel (po126) for my 2005 Mazda3i.

so oem thermostat and not one from advanced auto parts?
http://shop.advanceautoparts.com/webapp/wcs/stores/servlet/product_Xactstat&153;-Thermostat-Including-Housing,-180-Degrees-Fahrenheit-Stant_20480007-P_2523_R%7CGRPCOOLAMS_____

and if thats not the right part, then LINK?
[/quote]

I've found the ones from the auto parts stores to be of poor quality and fail pretty fast. Just go to the dealer and order one from there or get one from one of our vendors that is a dealer.
 

·
Registered
Joined
·
20 Posts
I dont know if this was mentioned in an earlier post, but there is actually a TSB out for the problem of the check engine light staying on/coming back on after having the thermostat replaced. Mazda needed to update my computer apparently. They did mine for free. The reference number is: 01-008/04

Just my :2cents:
 

·
Moderate your face
Joined
·
6,577 Posts
Discussion Starter · #7 ·

·
Registered
Joined
·
165 Posts
[quote author=mr.zoomie link=topic=202138.msg4171180#msg4171180 date=1326153470]
I dont know if this was mentioned in an earlier post, but there is actually a TSB out for the problem of the check engine light staying on/coming back on after having the thermostat replaced. Mazda needed to update my computer apparently. They did mine for free. The reference number is: 01-008/04

Just my :2cents:
[/quote]

+1 and i was told its covered up until 80,000mi
 

·
Registered
Joined
·
13 Posts
Re: How-To: Thermostat change (CEL P0125, P0126, P0128)

Hey guys (and gals). Long time lurker, newbie poster. I have an 05 3S that just hit 110K miles. I've had the dreaded P0128/P0126 off and on this winter and finally have the funds and time to fix the thermostat and hoping to do it myself (thanks to the awesome write up on this forum!). My concern is, I am not sure how long this issue has been going on. I purchased the car last April and by then it was warm enough outside not to have any issues -- I didn't have my OBD2 scanner until summer, so I am not sure what temps I was reaching in the spring. Once it started getting colder out the CEL became intermittent, throwing the P0128 and P0126 and my coolant temps would peak at 160* while driving. This concerns me, because I am not sure if this issue was present last winter before purchasing the car, and if that's the case I don't know how long the previous owner may have left this issue unattended.

Are there any steps I can take to reverse any potential damage that may have already been done to my motor? Or at least options to help prolong her life?

A bit of history on the car since purchased:
Oil was changed to run Mobil1 Full Synthetic 5w30 & Wix filter, oil is changed every 3000-3500 miles. Spark plugs changed about 10K miles ago to NGK Iridiums. Valve cover gasket changed 10K miles ago (leaky spark plug cylinder gaskets being the culprit).

Any suggestions are welcome. Thanks in advance for the help!
 

·
Registered
Joined
·
3,448 Posts
Re: How-To: Thermostat change (CEL P0125, P0126, P0128)

From my understanding, you should be ok, just replace your thermostat as soon as you can. What i got out of it is that the failed thermo just causes your car to take longer to warm up because the thermostat is stuck open, not allowing it to get to temp as fast as if it could be closed. I would just flush your coolant, replace the thermo, and you should be good to go. Unplug your battery when you do this and the ecu will reset. I had the same codes for few months before I got to replacing mine.
 

·
Registered
Joined
·
381 Posts
[quote author=mr.zoomie link=topic=202138.msg4171180#msg4171180 date=1326153470]
I dont know if this was mentioned in an earlier post, but there is actually a TSB out for the problem of the check engine light staying on/coming back on after having the thermostat replaced. Mazda needed to update my computer apparently. They did mine for free. The reference number is: 01-008/04

Just my :2cents:[/quote]

tsb covers cars out of warrenty?
(my 2005 mazda3i has 130k miles)

oh wait.. this is for the computer update, and not to replace the thermostat itself. :oops:
 

·
Registered
Joined
·
165 Posts
[quote author=a-sher link=topic=202138.msg4171646#msg4171646 date=1326231053]
i never paid for the computer update, waste of money IMO. My car's been running great

[/quote]


Its free.... if ur under 80,000 miles
 

·
Registered
Joined
·
3,448 Posts
[quote author=PHARAOH313 link=topic=202138.msg4171677#msg4171677 date=1326237731]
[quote author=a-sher link=topic=202138.msg4171646#msg4171646 date=1326231053]
i never paid for the computer update, waste of money IMO. My car's been running great

[/quote]


Its free.... if ur under 80,000 miles
[/quote] Care to explaing how? Not to mention most people with an 04-05 are probably over that already.

Mazda will charge 400 for the pcm update and thermostat install. A lot of people in the past got the pcm update first bc mazda said it would fix the problem, and never did. So then they had to replace their thermostats, and problem gone.
 

·
Registered
Joined
·
165 Posts
[quote author=a-sher link=topic=202138.msg4171991#msg4171991 date=1326297932]
[quote author=PHARAOH313 link=topic=202138.msg4171677#msg4171677 date=1326237731]
[quote author=a-sher link=topic=202138.msg4171646#msg4171646 date=1326231053]
i never paid for the computer update, waste of money IMO. My car's been running great

[/quote]


Its free.... if ur under 80,000 miles
[/quote] Care to explaing how? Not to mention most people with an 04-05 are probably over that already.

Mazda will charge 400 for the pcm update and thermostat install. A lot of people in the past got the pcm update first bc mazda said it would fix the problem, and never did. So then they had to replace their thermostats, and problem gone.
[/quote]

Sure ... no need to mention anyone no matter what year they have if they have over 80,000mi lol.. but i have an 05 and im under 80... :)

also i am only refering to the pcm update, if they have to replace ur thermo, thin it proubly was the thermo and the update wouldnt apply.. :lol:

when i had mine done they did the update 1st thin told me if the engine light comes back on thin they would need to change the thermo or temp sensor and it would cost me around $350-$400... :shock:

but any mazda defect/recall i was told buy the dealer is covered up to 80000 miles... :eek:

If anything call ur locale dealer and give them the service bulletin 01-008/04 and ask how long it is covered and that should answer any questions since im only repeting info that was told to me buy my dealer here in Jax... g/l
 

·
Registered
Joined
·
381 Posts
[quote author=dugger_8 link=topic=202138.msg4171193#msg4171193 date=1326155276]
[quote author=Silver3i link=topic=202138.msg4171171#msg4171171 date=1326153127]
is it this one? (from mazda dealer webpage)

http://parts.arlingtonmazda.com/products/SENSOR%2CTEMP.%252dENG.COO-%28L35G%252d18%252d840%29.html
[/quote]

That is a temp sensor, not a thermostat.

Updated OP with a link to a part number and diagram from a dealer. Verify with a dealer that the part number is correct for your vehicle. Reference purpose only.
[/quote]

thx, but your link only lists the part. no part #.

is this it?
http://parts.arlingtonmazda.com/products/THERMOSTAT-%28LF70%252d15%252d170%29.html
 

·
Moderate your face
Joined
·
6,577 Posts
Discussion Starter · #17 ·
[quote author=Silver3i link=topic=202138.msg4173273#msg4173273 date=1326499849]
[quote author=dugger_8 link=topic=202138.msg4171193#msg4171193 date=1326155276]
[quote author=Silver3i link=topic=202138.msg4171171#msg4171171 date=1326153127]
is it this one? (from mazda dealer webpage)

http://parts.arlingtonmazda.com/products/SENSOR%2CTEMP.%252dENG.COO-%28L35G%252d18%252d840%29.html
[/quote]

That is a temp sensor, not a thermostat.

Updated OP with a link to a part number and diagram from a dealer. Verify with a dealer that the part number is correct for your vehicle. Reference purpose only.
[/quote]

thx, but your link only lists the part. no part #.

is this it?
http://parts.arlingtonmazda.com/products/THERMOSTAT-%28LF70%252d15%252d170%29.html
[/quote]

Yes.
 

·
Registered
Joined
·
227 Posts
This code (p0128) came on for me back in mid October and it hasn't come back since. Should I be worry about it? I have inspection soon and don't want it to go on while its being inspected. lol.. Wonder if it was a glitch. :-/
 

·
Registered
Joined
·
381 Posts
how does it cost at the dealship to change the thermostat?
 
1 - 20 of 154 Posts
Top