Mazda3 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9,451 Posts
Discussion Starter #1
So, I was too lazy to find the computer thread that has been running for ages.

And since this one is a little different, here I go.

Anyone have a homebrew server running?

I put together a file server a few weeks ago for backups and file sharing between my machine and my wifes. As well as a secondary source for my media player (I normally use an extrenal USB connected to the media player, but I only update the files on it about once a month as I am too lazy to disconnect the thing, carry it over to my computer, load files up, carry it back). The server was also a result of finally wiring my house with Cat5e and a GbE switch.

Specs are
ASUS M4A78LT-M LE
Sempron 140
Antec 380d
Mushkin Enhanced Silverline DDR3 1333 1x2GB
Samsung F3 1tb
Samsung F4eg 2tb
Intel EXPI9301CT GbE NIC
Rosewill Blackbone case

Machine is running XP currently.

I had the damnedst time at first. I tried Ubuntu 10.10, but could get my Win7 machine to connect to the shares. I then moved on to XP since I still have a copy of 32bit professional. Loaded it up and another 4 or 5hrs of troubleshooting later (after 10 spent on Ubuntu and then FreeNAS) it turns out that I didn't have Microsoft client for file sharing installed on my Win7 box :shock:

I overlooked that little fact because I have never, in about 18 years of windows experience seen a machine with it defaulted to not be installed (obviously my Win7 Noobness). So installed it and it worked.

At 22MB/sec both ways. FRACK! That ain't gigabit speeds. Got a new NIC for my machine and the server (Intel NICs) still the speed problems. Played with the memory settings on the server in the registry and freed up speeds, played with the interupt moderation (IE turning it off) and now I've got line speeds both ways.

Only issue is that the server stubbornly refuses to do more than about 80MB/sec to the 1tb drive, even though it benchmarks faster than the 2tb drive. I think it is in part because I am using it as the boot drive (30gb partion on it). The biggest annoyance is that the server for the first 4-6 minutes after resuming from sleep will transfer the first 400-600MB at around 100-120MB/sec, then halt for about 5s, then resume at around 50MB/sec for the next 400MB or so, and then halt for another 5s and then resume at about 20MB/sec. After about 4-6 minutes and a single attempted file tranfer, everything is back up to full speed (Average of 115-120MB/sec to the 2TB drive and 80-90 on the 1TB drive). I've played with everything and nothing I've tried has worked.

I am stumped, so next week while the kids and wife are going I am ditching XP on the machine and installing Win7 as well as putting in a 30GB Onyx SSD for a boot drive. I am hoping this is some kind of wierd XP incompatibility with the hardware I am using. XP's netstack is pretty old (NT5 based, not NT6 based like Win7) on top of everything.

Future plans are an external eSATA enclosure for nightly backups w/ a couple of 2TB drives in it. For the network I am adding a VOIP appliance (Verizon FIOS is about $20 a month for the voice plan part of it I have right now...considering talk time, PAYG VOIP services are 2c a minute...my monthly bill would probably drop to $3-6 a month) and a 802.11b/g/n WAP. The Verizon router I have is only b/g and I get about 1.9MB/sec max from it. My wife's laptop lives 99% of the wirelessly, so a bit extra speed would be nice connecting to the file server.

Long story, but does anyone else have anything fun in their closet/basement/desk as a server?
 
1 - 5 of 5 Posts
Top