Mazda3 Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2,216 Posts
Discussion Starter · #1 ·
So I installed a 55 watt 6000k kit from xenon expert in my friends mustang, the kit works fine when the car is off, but when I start the car, the kit flickers and turns off

any ideas on how to fix it

with car off the battery gives off 12v
with car on and the alternator kicks in it gives off 14v, idk if this is the problem, but I have scratched my head for a while and cant find an answer

any help would be greatly appreciated
 

·
Registered
Joined
·
6,863 Posts
do you have a harness installed? and did your friend think about what he did by going with a 55watt hid kit in a halogen housing....
 

·
Registered
Joined
·
4,723 Posts
[quote author=leffler9 link=topic=134282.msg2886691#msg2886691 date=1232760520]
So I installed a 55 watt 6000k kit from xenon expert in my friends mustang, the kit works fine when the car is off, but when I start the car, the kit flickers and turns off

any ideas on how to fix it

with car off the battery gives off 12v
with car on and the alternator kicks in it gives off 14v, idk if this is the problem, but I have scratched my head for a while and cant find an answer

any help would be greatly appreciated
[/quote]

ran into the same problem a few days ago. Harness doesn't fix it. Neither does BOW eliminators.

You have to hook it up to the high beam and use the high beam switch to control it
 

·
Registered
Joined
·
6,863 Posts
that's odd. So when you want to turn your HID's on you got to flip the high beams on?
 

·
Registered
Joined
·
4,723 Posts
[quote author=08mazda2.0 link=topic=134282.msg2888086#msg2888086 date=1232832032]
that's odd. So when you want to turn your HID's on you got to flip the high beams on?
[/quote]

yes. not really any way around it.
 

·
Registered
Joined
·
6,092 Posts
had the same problems with my sis in laws compass
but since it was a bi xenon hid kit i couldnt leave the hi beams on
but i got it to work, dont recall how but i didnt hook it up to anything else, but the relay harness helped

but i would highly recommend using the relay harness first before anything else.
same trouble with a f150 added a harness and it was better.
 
1 - 8 of 8 Posts
Top