Mazda3 Forums banner

1 - 20 of 24 Posts

·
Registered
Joined
·
184 Posts
Discussion Starter · #1 ·
Its probably on here but I cant find it. I have the factory HID`s and i`m looking to get some HID fogs and I want the color to match the factory HID headlights,does anyone know if its possible and if so who`s kit how much,and how hard to install. Thanks
 

·
Registered
Joined
·
382 Posts
Also make sure you choose H11 bulb size seeing how you have a 2006.

Install is basically plug and play for the kit I linked. Pretty easy stuff.
 

·
Registered
Joined
·
184 Posts
Discussion Starter · #4 ·
Thanks for the info, is there a difference between the kit you got and the other ones found on the forum, quality,reliability,install,price, and the 45000k they wont have any yellow to them right, just like the stock hid headlights? Thanks
 

·
Registered
Joined
·
5,673 Posts
[quote author=shelby link=topic=136815.msg2951661#msg2951661 date=1235195088]
Thanks for the info, is there a difference between the kit you got and the other ones found on the forum, quality,reliability,install,price, and the 45000k they wont have any yellow to them right, just like the stock hid headlights? Thanks
[/quote]

There's differences in all kits in prices and quality. Best kits are ones that use Japanese parts like Volts and Xtreme 4300K will not have yellow like the stock ones.
 

·
Registered
Joined
·
382 Posts
Yeah, the way the fogs are designed it's not really worth the 55w upgrade. 35w will do the job well and 55w will blind oncoming severly anyway.
 

·
Registered
Joined
·
184 Posts
Discussion Starter · #9 ·
Well i just installed the 35w kit into my fogs and the passenger side light wont fire up. I turned the switch on and off a couple of times and it lit, well tried to and then it shut off. That happened a couple of times and it finally lit after a few minutes it turned the same color as the driver`s side. I ran to a couple of stores and it shut off again. I went over all the wiring and checked the grounds all is good, but still wont light. Any suggestions
 

·
Registered
Joined
·
268 Posts
Do you have the wiring harness for it? If not, buy it. Mine wouldn't fire up at all without it. That is probably the fix if you don't have it already.
 

·
Registered
Joined
·
184 Posts
Discussion Starter · #11 ·
I do have the harness and I checked all the connections. I emailed oliver but have not gotten a reply. The light seems to be down on power, when it does light it takes a few minutes to get to full power.
 

·
Registered
Joined
·
268 Posts
A few SECONDS if the correct amount of time for it to fire up completely. Try swapping the ballast's on each side and see if it's the same way on the opposite bulb. If it does the same thing, it's the ballast. If not, it's the bulb. I've emailed him and haven't gotten a reply yet as well. To me, it sounds like the ballast, but I could be wrong.
 

·
Registered
Joined
·
184 Posts
Discussion Starter · #13 ·
Yeah that`s what I was thinking it was, i`ll try that tomorrow switch them, but like you said I think it`s the ballast. People have said there customer service is good, I hope it still is..
 

·
Registered
Joined
·
268 Posts
I'm sure it still is. Oliver is a damn good guy, and I have complete faith in everything he does and says. It was my ballast that was bad as well, and the sad thing is, is that I had that ballast hooked up to my driver side low beam. Watching that thing flicker is the most irritating thing I have ever dealt with. So I switched it to the driver side fog light and it doesn't bother me at all now. Especially since I took the fog light reflector bowls out.
 

·
Registered
Joined
·
184 Posts
Discussion Starter · #15 ·
I tried switching the ballast today and still have the same problem.When i installed the kit my bulbs would not fit in the fog light housing it would hit that little cover in the fog light, so i just pushed it forward a little bit with a screwdriver and the hid`s fit no problem. I just wish when I do mods to my car I only have to do it once, it gets a little old redoing time and time again the same mod. :boom:
 

·
Registered
Joined
·
268 Posts
I know what you mean. The fog light shouldn't have touched the reflector bowl in the fog light. As far as I know, we both have the exact same type of fog light housing, and I haven't had any problem with the fitment of the HID bulb. I actually decided to take out the reflector bowl in both of the fog lights, and good god is it bright!
 

·
Registered
Joined
·
184 Posts
Discussion Starter · #17 ·
Yeah I thought about doing that to but wasnt sure if it would blind oncoming drivers. I still have not heard from oliver yet hopefully tomorrow, if not i`ll send another email.
 

·
Registered
Joined
·
268 Posts
I just installed some Lamin-X on the fogs today and painted the surrounds, (both the black and silver plastic parts), and it is definitely yellower than it was, and a lot dimmer. Even before I put on the Lamin-X, I was driving around with the fogs aimed all the way up, which I might add, really puts the light on the road. You can see a difference in the brightness with and without the fogs on.
 
1 - 20 of 24 Posts
Top