Mazda3 Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Does anyone else have this problem?? Whenever I bang gears, from first to second, the engine bangs back at me hard. Like a loud boom/hard pop. It kinda scares me like the engine is going to drop. Anyway, it's never been like that in any other car I've driven and it seems odd. But since day 1 it's been that way. I have 28k miles on the warranty and wonder if it's a credible request to them...

Thanks to anyone who can help

Ted - NJ
Black 2007 MS3 GT
 

·
Registered
Joined
·
688 Posts
Stock rear motor mount allows way too much movement of the engine under hard acceleration and shifting. Replacing the mount with an aftermarket mount will solve that issue, among others.
 

·
Registered
Joined
·
2,788 Posts
NORMAL? yes

GOOD? no

rear motor mount is way too soft in this car. consider at least corksport inserts, but I would recommend a full mount. take a look around the forums. It makes shifting so much better too
 

·
Registered
Joined
·
371 Posts
many people have said the banging you hear (if it isn't wheel hop) is the downpipe/exhaust hitting up against the crossmember? or is it just the bottom of the car? But yea it's because the engine moves so much due to the soft rear engine mount.
 

·
Registered
Joined
·
422 Posts
Yep.... excess engine movement.

Step 1: new rear mount (full replacement like CP-e, Street Unit, TRZ Dogbone, etc.)

Step 2: replace passenger side engine mount and tranny mount.
 
1 - 6 of 6 Posts
Top