Mazda3 Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
114 Posts
Discussion Starter · #1 ·
Ok - So this morning on my way to work, I was on a busy 3 lane expressway in stop-and-go traffic and my engine's rpms dropped and then just died. Totally random...and scary :shock: I was basically stopped when it happened, maybe going 10 or 15 mph and coming to a stop. Initially, it seemed like misfires, but instead of just jerking, it just died. Now, a couple weeks ago I had put in a SRI, but have had no problems at all. I reset the ECU after the install and never experienced anything like it before. Anyone have an idea of what caused it? Intake? Thanks!
 

·
Registered
Joined
·
10,880 Posts
I've had mine do that in stop/go traffic or while coming to a stop... maybe 2-3 times in 2.5 years... if you didn't get a CEL or anything, could just be a spot of bad gas with the hot/cold we've been getting...
 

·
Registered
Joined
·
114 Posts
Discussion Starter · #3 ·
Weird....the thing is I was in such a panic I don't remember if the CEL came on before the engine died or when it comes on with all the other lights when the key is in the ON position. I definitely saw the CEL though. After calming myself down, I just put it in park, took the key out, put it in and restarted. It started up fine and no CEL after that...

BTW...it is an automatic, so I didn't stall a manual. The intake is a Cosmo Racing SRI with a AEM dryflow if that helps.
 

·
Registered
Joined
·
10,880 Posts
CEL just comes on when it died... if it wasn't there when it came back then no worries man...

If it happens again I'd try getting a full tank of fresh gas... If you do throw a code go get it read, and check the MAF wires in a worse case scenario bit...
 

·
Registered
Joined
·
114 Posts
Discussion Starter · #5 ·
[quote author=aps11090 link=topic=139290.msg3002567#msg3002567 date=1237410218]
CEL just comes on when it died... if it wasn't there when it came back then no worries man...

If it happens again I'd try getting a full tank of fresh gas... If you do throw a code go get it read, and check the MAF wires in a worse case scenario bit...
[/quote]

ok cool....thanks for your input
 

·
Registered
Joined
·
114 Posts
Discussion Starter · #6 ·
Ok...now I'm freaking out. Yesterday the same thing happened. As I was slowing to a stop, maybe around 15-20mph, the CEL flashed for a split second and the RPM's dropped. I was able to give a little gas and get them back up before it stalled again on me. WTF is going on? Does the ECU remember the last CEL codes it would have had? I wish I could find out why it came on....
 

·
Registered
Joined
·
10,880 Posts
[quote author=tremonti93 link=topic=139290.msg3006129#msg3006129 date=1237553177]
Ok...now I'm freaking out. Yesterday the same thing happened. As I was slowing to a stop, maybe around 15-20mph, the CEL flashed for a split second and the RPM's dropped. I was able to give a little gas and get them back up before it stalled again on me. WTF is going on? Does the ECU remember the last CEL codes it would have had? I wish I could find out why it came on....
[/quote]

Did you refill your tank yet? I'd check MAF wires, and get some fuel cleaner/octane booster or something and fill your tank again... if the 'cel' flashed for a minute it just means your car almost stalled, it wasn't that you actually threw a CEL...
 

·
Registered
Joined
·
91 Posts
My vote goes to bad gas. Fill it up and put in some dry gas if it's not the 10% ethanol stuff. If that didn't/doesn't help, then maybe some injector cleaner. Also take a look at the MAF. If none of that, then maybe fuel filter/pump.

The CEL would forget codes if the power shut off, but it doesn't sound like an electrical problem.
 

·
Registered
Joined
·
114 Posts
Discussion Starter · #9 ·
thanks guys...I still have half a tank though. Should I just fill it now or wait til I use the rest? Also, any suggestions on the fuel cleaner?
 

·
Registered
Joined
·
91 Posts
I'd go ahead and fill it now. It could save you a bunch of trouble on the road. If the problem is water in the gas, any reputable brand of alcohol-based water absorber will do the job. If you're using gas with 10% ethanol, then it shouldn't be necessary.

If you're looking for an injector cleaner, I don't have a particular brand I swear by, though I'm sure others will have strong opinions...
 

·
Registered
Joined
·
10,880 Posts
It's all the same... Throw some 120 proof in there haha.

Any drygas/inj cleaner you grab at a gas station will at least give you an idea for now... it's an 07 so unless you had some REAL bad gas, it's probably just some water/moisture... I assume your air filter is dry as well...
 

·
Registered
Joined
·
10,880 Posts
[quote author=tremonti93 link=topic=139290.msg3007219#msg3007219 date=1237582315]
Ok...again thanks guys. I'll fill it up today. Much appreciated.
[/quote]

Come out to the OCC meet as well ;) And EECMM too... lol
 
1 - 13 of 13 Posts
Top