Mazda3 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,933 Posts
Discussion Starter #1
Lately I've noticed that my lights dim down and back up continuosly with acceleration and deceleration. It wasn't doing that before and it's not just a little bit, there's actually quite a bit of difference in the intensity of the head lights. Any idea what might be causing this? p.s. I have an Apexi ground kit.
 

·
Registered
Joined
·
781 Posts
Sounds similar to the issue I was having with my Buddy Club Condenser, except it would almost kill my car and then once everything "reset" the car came back to life. Then I couldn't start it one morning on my way to work after stopping to get gas. Once the BCC was totally removed the car started right up. Oddest thing. If it's not too much trouble I would suggest disconnecting the grounding kit completely and seeing if that helps at all.
 

·
Registered
Joined
·
1,732 Posts
I have this issue as well, but it only happens when the rear defroster, headlights, fan, and radio are all on. Do you think a grounding kit would help me?
 

·
Registered
Joined
·
781 Posts
[quote author=ViperKillerWannabe link=topic=68843.msg1191124#msg1191124 date=1170814495]
I have this issue as well, but it only happens when the rear defroster, headlights, fan, and radio are all on. Do you think a grounding kit would help me?
[/quote]

It definitely can't hurt to run some thicker cables from one side of the engine bay to the point where the batterie's negative connection is on the fender. I'm kind of skeptical about earthing kits and voltage stabilizers in one now that somebody else is having a similar problem as me.

One thing to note though is the 3 has a very low rated alternator which is probably the root of all of our problems.
 
1 - 6 of 6 Posts
Top