Mazda3 Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1,153 Posts
Discussion Starter · #1 ·
Well, I had the already known to some people, P0128 CEL something about cooling system. However, shortly after it came up my exhaust started sounding deeper, as If I had a tip installed or something, mainly under 2k RPMs, and it keeps creepin up the tach to about 2k now. Also I checked the tip of my car and the bottom half seems incredibly dirty, dark, maybe running extra rich? My cel says cooling system but I had the same CEL come up before and It was coupled with another code saying it was too rich at idle. Now that code is gone. But it could still be happening? Any ideas guys, I have had a small performance/ gas mileage drop also. I want to get a few ideas before dumping out the big buxs. Thanks in advance everyone. :(
 

·
Registered
Joined
·
1,153 Posts
Discussion Starter · #2 ·
also, when holding the gas down slightly on most gears the car ricks slightly back and forth not just a smooth cruise. Maybe its because its manual???? any help guys
 

·
Registered
Joined
·
5,030 Posts
For the engine rocking, it's probably one or multiple motor mounts that are gone. The passenger side one next to the coolant reservoir is usually the problem one.
 

·
Registered
Joined
·
1,438 Posts
[quote author=manny link=topic=139969.msg3023043#msg3023043 date=1238256525]
For the engine rocking, it's probably one or multiple motor mounts that are gone. The passenger side one next to the coolant reservoir is usually the problem one.
[/quote]

He's already had those replaced.

Zabusa, if you keep this stuff in your old thread, you will get more attention. Having this stuff in multiple areas is just confusing. You can always edit the title of your first post (in your original thread) to reflect your latest problem.

As far as the CELs go, I still say you should replace your thermostat. Eliminating problems one by one is a good strategy. It also sounds like your cat may be going south, but I couldn't be sure.
 
1 - 6 of 6 Posts
Top