Mazda3 Forums banner

1 - 20 of 27 Posts

·
Registered
Joined
·
2,348 Posts
Discussion Starter #1
I am not a newbie to big HP turbos. I am, however, a newbie to the new generation of computer mapping and timing when it comes to turbos. I always believed small in and big out for max turbo response. Now, it could all be in my head, but my car feels SLOWER. I have taken it through the RPM's slowly and quickly, but I do not feel the slightest bit of increase. I added the HKS BOV a couple days later to properly vent the turbo, but I just can't shake the feeling that I am missing out on some of my POWER! I am tempted to stick the airbox back on to do a quick run just to confirm my suspicious mind. Any thoughts? I did reset my computer... just to avoid that question a hundred times.
 

·
Registered
Joined
·
2,622 Posts
Re: CPE CAI... anyone noticed a decrease in low-end?

Did you reset the ECU? :lol: just kidding.

Seriously, for me, I did not lose low end at all. I know my car is happier at higher RMPs, and was like that stock. Heck my P5 was like that, too. I am not sure what to think.
 

·
Registered
Joined
·
355 Posts
Re: CPE CAI... anyone noticed a decrease in low-end?

did you reset the ecu?

:klavergreg: :klavergreg:sorry...had to do it.

anyways, depending on when you put on the CAI, the computer may still be adjusting to it. Ive heard it can take a couple hundred miles sometimes...I HOPE thats it, because I have the same intake waiting to be installed on my car which i am waiting to have delivered.

I have an idea...get the ecu tuned for an extra 600-1000$$$ and that will eliminate all of your power concerns!
 

·
Registered
Joined
·
612 Posts
Re: CPE CAI... anyone noticed a decrease in low-end?

sounds like VTA... no one reads. :?
 

·
Registered
Joined
·
2,348 Posts
Discussion Starter #6
Re: CPE CAI... anyone noticed a decrease in low-end?

I am running it in recirc. it really could all be in my head, or maybe it is just going to take a couple drive cycles to get used to it.

nothing a new turbo-back exhaust can't fix!
 

·
Registered
Joined
·
1,870 Posts
Re: CPE CAI... anyone noticed a decrease in low-end?

[quote author=diablospeed link=topic=69962.msg1217979#msg1217979 date=1171944227]
I am not a newbie to big HP turbos. I am, however, a newbie to the new generation of computer mapping and timing when it comes to turbos. I always believed small in and big out for max turbo response. Now, it could all be in my head, but my car feels SLOWER. I have taken it through the RPM's slowly and quickly, but I do not feel the slightest bit of increase. I added the HKS BOV a couple days later to properly vent the turbo, but I just can't shake the feeling that I am missing out on some of my POWER! I am tempted to stick the airbox back on to do a quick run just to confirm my suspicious mind. Any thoughts? I did reset my computer... just to avoid that question a hundred times.
[/quote]

I think a cai traditionally adds a bit of higher end hp at the expense of lower end torque....or is that a catback? either way, something usually changes in the torque/hp map as to where and how much is made when you make changes...so your observation could be valid. Try a highway, higher rpm pull and see if you can notice the difference. it could be in your head, or it could be your expectations getting the better of you....only a before and after dyno would solve the issue.
 

·
Registered
Joined
·
2,348 Posts
Discussion Starter #8
Re: CPE CAI... anyone noticed a decrease in low-end?

ok... I believe the issue is solved. The HKS BOV is VERY VERY tempermental. I had a notion that the snap ring was not seated properly, and might be causing a loss of pressure at the o-ring. My concerns were correct. I took off the BOV and saw that there was about a one inch portion of the ring that was pulled away from the seat. I replaced the factory BOV and the problem was solved.

I;m an idiot I guess.

THanks for the help guys.
 

·
Registered
Joined
·
355 Posts
Re: CPE CAI... anyone noticed a decrease in low-end?

[quote author=diablospeed link=topic=69962.msg1220209#msg1220209 date=1172029450]
ok... I believe the issue is solved. The HKS BOV is VERY VERY tempermental. I had a notion that the snap ring was not seated properly, and might be causing a loss of pressure at the o-ring. My concerns were correct. I took off the BOV and saw that there was about a one inch portion of the ring that was pulled away from the seat. I replaced the factory BOV and the problem was solved.

I;m an idiot I guess.

THanks for the help guys.
[/quote]

Are you still going to use the HKS ?
 

·
Registered
Joined
·
2,348 Posts
Discussion Starter #11
Re: CPE CAI... anyone noticed a decrease in low-end?

i think i'm going to sell the HKS... I really don't need one right at the moment anyways, and it would free up some additional cash for exhaust. as far as performance goes it is a demon again. the intake affect is now felt.
 

·
Registered
Joined
·
93 Posts
Re: CPE CAI... anyone noticed a decrease in low-end?

[quote author=diablospeed link=topic=69962.msg1220802#msg1220802 date=1172069266]
i think i'm going to sell the HKS... I really don't need one right at the moment anyways, and it would free up some additional cash for exhaust. as far as performance goes it is a demon again. the intake affect is now felt.
[/quote]
hit me up if u wanna sell it
ill buy it for sure
 

·
Registered
Joined
·
1,842 Posts
Re: CPE CAI... anyone noticed a decrease in low-end?

[quote author=diablospeed link=topic=69962.msg1220209#msg1220209 date=1172029450]
ok... I believe the issue is solved. The HKS BOV is VERY VERY tempermental. I had a notion that the snap ring was not seated properly, and might be causing a loss of pressure at the o-ring. My concerns were correct. I took off the BOV and saw that there was about a one inch portion of the ring that was pulled away from the seat. I replaced the factory BOV and the problem was solved.

I;m an idiot I guess.

THanks for the help guys.
[/quote]

ok...u put the factory bov back on!? .....did you cut an inch of the hose off when u install the hks bov....???
 

·
Registered
Joined
·
2,348 Posts
Discussion Starter #14
Re: CPE CAI... anyone noticed a decrease in low-end?

i have gone back to stock BOV since then. i purchased street unit's soon-to-be-released BOV in black though.

need that and COBB's FMIC, some tuning and I am done.
 

·
Registered
Joined
·
1,842 Posts
did you cut your hose when u first install the hks bov??
 

·
Registered
Joined
·
411 Posts
Yet another thread showing how unnecessary a BOV is at these power levels.

I have the new Injen CAI on my MS3, and i notice a little low end power loss, if i'm not getting on it. In stop and go traffic, when im not winding out the car and spooling the turbo, there is a little less pull in the lower RPM's. I chalk that up to a longer intake path, instead of an 8 inch plastic hose from the airbox, there's now 2 feet of pipe from the fenderwell. But the power gains are VERY noticeable once that turbo gets to spooling.
 

·
Registered
Joined
·
355 Posts
Re: CPE CAI... anyone noticed a decrease in low-end?

[quote author=udontknowajck link=topic=69962.msg1428229#msg1428229 date=1179797072]
[quote author=diablospeed link=topic=69962.msg1220209#msg1220209 date=1172029450]
ok... I believe the issue is solved. The HKS BOV is VERY VERY tempermental. I had a notion that the snap ring was not seated properly, and might be causing a loss of pressure at the o-ring. My concerns were correct. I took off the BOV and saw that there was about a one inch portion of the ring that was pulled away from the seat. I replaced the factory BOV and the problem was solved.

I;m an idiot I guess.

THanks for the help guys.
[/quote]

ok...u put the factory bov back on!? .....did you cut an inch of the hose off when u install the hks bov....???
[/quote]


does this eliminate some of the issues that are arising?
 

·
Registered
Joined
·
2,348 Posts
Discussion Starter #19
i did cut the hose... but got another when I backed up to stock.


what issues are with BOV's??

I am not aware of real issues yet.
 

·
Registered
Joined
·
83 Posts
I have the CPE CAI too and I feel like I lost power too, I have the stock BOV. I guess it's only in the low end, but it's driving me crazy. I don't know if it's me getting used to the power or an actual change in power. But at high speeds I feel like I keep up better then I should with my roomies Evo MR and a Porsche Turbo. I would love to see a dyno of the stock air box, and then the CPE CAI on the same car. And in 5th gear, the dyno I did was done in 4th and I think on our cars 5th is closer to a 1:1 ratio then 4th.
 
1 - 20 of 27 Posts
Top