Mazda3 Forums banner

1 - 20 of 32 Posts

·
Banned
Joined
·
487 Posts
Discussion Starter · #1 ·
so here is my situation. i just put in springs on wednesday, and installed corksport inserts roughly a month ago.

as of three days ago, there is a squeaking noise when i clutch in. in addition i get the squeaking when i have low rpms in 1st, and then add more gas quickly, i get the squeak, or when i accelerate fast from a standstill.

i hear the squeak even more when my car is on a downward slope, making me believe that the motor mount bolts aren't tight leading it to squeak and slide down a bit...


at first i thought it was my springs or f+/or r sway bar, but its not really a clunking and it doesn't sound like its in the rear at all, more concentrated right under the car.

or do you really think its the springs...i thought springs had a distinct sound...and when i go over bumps going slow and/or fast i hear nothing...its only when using the clutch

so you think i should retighten the motor mount bolts and add loctite (maybe should have done it first time) ? or is it something else

its really pissing me off, as im really anal about squeaks and everything needs to be perfect


oh and when i shut off my car...obviously my car was not moving...the squeak was evident....and i was in neutral with parking brake on, foot off all pedals
 

·
Registered
Joined
·
2,423 Posts
Re: Squeaking sound when clutching in and giving gas and clutching out

the clutch in i did... dealer replaced my clutch slave and ended up messing up my cruise control.
 

·
Banned
Joined
·
487 Posts
Discussion Starter · #4 ·
Re: Squeaking sound when clutching in and giving gas and clutching out

actually i am 99% sure its the inserts making the slight squeak. ironically it only makes the squeak when it was wet, which was three days ago and yesterday, the days i actually heard them squeak. so is there a way to quiet them down by adding grease or something, or is that just the nature of polyurethane?
 

·
Registered
Joined
·
565 Posts

·
Banned
Joined
·
487 Posts
Discussion Starter · #6 ·
Re: Squeaking sound when clutching in and giving gas and clutching out

hmmm i don't think thats the same noise.

what im gonna do is check to see if the motor mount bolts are tight...if they are then i might take the inserts out and see if it makes the same noise. if it stops the noise ill probably go with another aftermarket mount or something else altogether since i hate squeaks haha..but we'll see. hopefully the bolt is loose or something for my sake.

if i get new mount, which would be better medieval or cpe...heard both have minimal vibrations compared to teh CS inserts, SU mount, AWR mount and TRZ poly mount...
 

·
Banned
Joined
·
487 Posts
Discussion Starter · #8 ·
Re: Squeaking sound when clutching in and giving gas and clutching out

i have some silicon spray...could i just get under the car and spray away and see if it goes away?
 

·
Banned
Joined
·
487 Posts
Discussion Starter · #9 ·
still have this problem, and its ONLY when wet out....yesterday i was driving around and it would squeak when applying and reapplying throttle in 1st and 2nd gear....but today i accelerated the same exact way and i don't hear a thing...only happens when there is water on the road/rain....?

im assuming its the inserts, so what should i do, upgrade to a full mount? i might take out the inserts to make sure 100% that its that before i go buy a real mount...
 

·
Registered
Joined
·
10,527 Posts
[quote author=babypetit link=topic=137094.msg3007074#msg3007074 date=1237578523]
im assuming its the inserts, so what should i do, upgrade to a full mount? i might take out the inserts to make sure 100% that its that before i go buy a real mount...
[/quote]

I was going to suggest you do that first, but you beat me to it. :lol:

I've had my inserts in for month and I don't have any squeaking problems with them.
 

·
Banned
Joined
·
487 Posts
Discussion Starter · #11 ·
ya i know its really pissing me off....i mean if i grease the crap out of them eventually the squeak will come back so i will probably just get a real mount
 

·
Registered
Joined
·
6,863 Posts
take them out and throw them away and buy the darkstar mount. I had the inserts and after a couple months it felt like they didn't even exist. They did nothing for performance after a while. My darkstar mount gives no vibes once so ever. Its quieter than the CS inserts and when i shift, i deff feel that it does do something.
 

·
Banned
Joined
·
487 Posts
Discussion Starter · #13 ·
you mean the medieval mount? does it have less shudder than the CS inserts, because I still get the nasty shudder since i always start the car revving less than 1000 rpms..
 

·
Registered
Joined
·
6,863 Posts
yep thats exactly what i am talking about. When i first installed it. It had slight vibes but even those vibes were less than the CS inserts. And after driving with it for a week. I had no vibes once so ever. When i had the CS inserts the cars dash vibrated. With this mount i got no vibration and people can't even notice i have a mount. My dad drove my car after and didn't complain once so ever, vs the time when i had the CS inserts he said "you made your car feel like its falling apart".
 

·
Banned
Joined
·
487 Posts
Discussion Starter · #15 ·
[quote author=08mazda2.0 link=topic=137094.msg3007238#msg3007238 date=1237582975]
yep thats exactly what i am talking about. When i first installed it. It had slight vibes but even those vibes were less than the CS inserts. And after driving with it for a week. I had no vibes once so ever. When i had the CS inserts the cars dash vibrated. With this mount i got no vibration and people can't even notice i have a mount. My dad drove my car after and didn't complain once so ever, vs the time when i had the CS inserts he said "you made your car feel like its falling apart".
[/quote]

oh really which one did you get, because the one on their website doesnt look like the one they had in the previous GB:

http://www.darkstarmotorsports.com/index_files/Page1735.htm


ps. im also surpsied no one else has gotten squeaks. i mean these inserts are polyurethane, and i did some google searches and everyone says that this urethane squeaks like crazy if not greased properly.....
 

·
Registered
Joined
·
6,863 Posts
mine squeaked but very little and plus i always had my music on so i never bothered with it.

Yea there older style just looks nice this new one looks like the TRZ mount but they use the same material so you get the same results as the other model. I am guessing they did it to eliminate the 2 piece and make it cheaper.
 

·
Registered
Joined
·
5,030 Posts
Ya, I'd scrap the inserts. They don't perform that much better. And your car will vibrate like a mofo with the a/c on. I'd recommend that you get a rear motor mount. I have the street unit motor mount and the vibrations are minimal and they are much better than the inserts. If you've got the money, I'd go for the cp-e rear mount. Their side mounts are supposed to be a sweet piece of engineering, you can get those later down the road just to keep everything uniform.
 

·
Banned
Joined
·
487 Posts
Discussion Starter · #18 ·
[quote author=manny link=topic=137094.msg3008180#msg3008180 date=1237612959]
Ya, I'd scrap the inserts. They don't perform that much better. And your car will vibrate like a mofo with the a/c on. I'd recommend that you get a rear motor mount. I have the street unit motor mount and the vibrations are minimal and they are much better than the inserts. If you've got the money, I'd go for the cp-e rear mount. Their side mounts are supposed to be a sweet piece of engineering, you can get those later down the road just to keep everything uniform.
[/quote]

wait so you've had the SU mount and the CS inserts, and you think the vibrations and shudder when starting from a stop are better with the SU Mount?
 

·
Registered
Joined
·
5,030 Posts
Yup. I had a the inserts for a few months, so I definitely gave them a chance to break in. I had no intentions of buying an aftermarket mount, but a local member was parting out and I couldn't pass up on the offer. They perform much better and the vibrations are significantly less whether you are idling with the a/c on or start off from a stop.
 

·
Banned
Joined
·
487 Posts
Discussion Starter · #20 ·
hmmm sounds good...now i am not sure which mount to get. TRZ poly dogbone is too rough as ive heard, awr has bad vibrations...medieval mount sounds good, but they got rid of the aluminum version and only have steel...and i haven't heard any reviews, CP-E mount, but its hard to get one of those, and the SU mount, which everyone pretty much loves...

its weird the speed3 owners say streetunit mount has more vibrations and the CS inserts you feel nothing, but the mz3 owners say CS inserts are harsher than some of the real mounts....is this cause of the extra space in the mz3 mount, so adding the inserts makes it stiffer than the speed3 with less gaps in the mount?
 
1 - 20 of 32 Posts
Top