Mazda3 Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I just bought a second hand mazda 3 2007 diesel 1998 sport. The AC doesn't seem to be working. The compressor turns on for about 2 to 3 seconds, blows cold air and them turns off for about 15 to 20 seconds blowing warm air. I had it checked by a couple of AC guys, had the compressor replaced but still same story. Anyone here come across a thing like this before? And if so, what's the fix? I am desperate here. Its more of a heater than an AC right now.
 

·
Registered
Joined
·
30 Posts
You could have a faulty thermostat, a clogged/dirty air filter contributing to the problem, low refrigerant levels (the most typical issue), or a blockage in the system.

Has anyone put dye in the system and looked for leaks?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
You could have a faulty thermostat, a clogged/dirty air filter contributing to the problem, low refrigerant levels (the most typical issue), or a blockage in the system.

Has anyone put dye in the system and looked for leaks?
Yeah no leaks. There was a bit too much gas in it when I checked. I just took it back in to get checked for clogs and filter again. Will post what happens.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Yeah no leaks. There was a bit too much gas in it when I checked. I just took it back in to get checked for clogs and filter again. Will post what happens.
Yeah filters were fine, no clogs detected. The tech was saying it might be a faulty pressure sensor or the thermostat. Gonna take it in again on Monday to see what comes up.
 
1 - 4 of 4 Posts
Top