Mazda3 Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
266 Posts
Discussion Starter #1
It’s been -20c the last few nights and I notice the 3 seems to have to turn over a few times before it fires... where is some of my other cars fire rate away. Also it seems to rev at about 2500-3000rpm for about 2min before going down to 1500rpm then about 5min later 750rpm I have the 2.0 Standard 05... Anyone else’s having this issue or is it normal for this car? Or should I take it in to get it looked at?
 

·
Registered
Joined
·
3,493 Posts
The car shouldn't be hard to start, but it's normal for it to rev high while warming up...my 2.3L revs at about 2k RPM for a minute or so before settling down. I think our engines do that because they're smaller and have aluminum blocks, which shed heat faster than iron blocks. Bigger engine = quicker warmup.
 

·
Registered
Joined
·
5,390 Posts
Mine has definately felt the cold freeze these past couple days. It is also hard to start, but after a couple turns, she's ready to roll.
 

·
Registered
Joined
·
14,227 Posts
mine had a hard to start moment today. It was 8*F (what is that? -5C?) The starter had to work for it's money before the engine started and the revs jumping up (which is normal for this car in the car)
 
G

·
Guest
Joined
·
0 Posts
My 2.0 was a little grouchy on cold mornings too....I don't think it's a cause for worry. Every car is programmed a little differently for cold startups. My Frontier turns MAYBE one revolution and rockets straight to 2000 without a hiccup, where my 3 was a little groggy at wake-up time. It's actually better to take a few turns before firing, as oil has begun to circulate before rpms rise.
 

·
Registered
Joined
·
1,813 Posts
I SOMETIMES have 2 noises that pop up upon startup cold or warm weather:
Belt driven noise and what sounds like internal engine lifter, valves?

Any ideas?
Is it an issue or is it moisture causing the belts to act up:?:
 

·
Registered
Joined
·
3,160 Posts
oooooh, sometimes I hear clicking after cold starts. :)

and Sometimes it takes about 5 cycles before the engine starts...

Nothing too worried.

Twice, my TPMS went off because it was cold enough to drop my tire pressure.
 

·
Registered
Joined
·
190 Posts
When its cold I start mine the same way...I turn the key and it starts.... :dunno: I guess i dont see a big deal with starting a car in the cold. The procedure is the same... :?
 

·
Registered
Joined
·
186 Posts
The colder it gets, the longer mine typically takes to start up and get down to around 1000 RPM. Then it's a big sluggish for a while until it gets nice and warm. That's just the way it is, it seems.
 

·
Registered
Joined
·
1,019 Posts
Man this really pisses me off. Before my old car was stolen, I picked up this amazing extension cord. The kind that never gets hard. Before even using it ocne, the damned weather got warm (thank god!!) then the car got stolen spring-summer!
Mine sounds just like truf's. Well, 1-3 turns and she's up to 2k. Holds for a min and it's wakey wakey, eggs n bakey!
 
1 - 12 of 12 Posts
Top