Mazda3 Forums banner

1 - 20 of 32 Posts

·
Registered
Joined
·
10,239 Posts
Discussion Starter #1
Well, I got a CEL today and brought it to have it scanned. The 3 codes read: P2187 - System to lean @ idle and P2177 - System to lean off idle speed. The first code (P2187) was thrown twice out of the three codes.

Does anybody know what this could be? I was told it can be a multiple amount of things. That I wouldn't be able to find out exactly what's wrong unless I get the real, whole engine diagnostic for $85... suggestions?
 

·
Registered
Joined
·
10,538 Posts
Re: CEL

it means (not makes) your A/F ratio is off.


unless i'm stating the obvious to you? it could be a bunch of things they're right. what kind of mods do you have?
 

·
Registered
Joined
·
12,565 Posts
Re: CEL

[quote author=small town king link=topic=66559.msg1141874#msg1141874 date=1168400552]
it makes your A/F ratio is off.


unless i'm stating the obvious to you? it could be a bunch of things they're right. what kind of mods do you have?
[/quote]

As far as I know, his engine is stock. Sounds like it needs to be taken into the dealer.
 

·
Registered
Joined
·
10,538 Posts
Re: CEL

our ECU's might be really sensitive to A/F ratios. but then again, they might not be. i'd take it in for sure. if you're udner 50k, it'll be warrantied for sure
 

·
Registered
Joined
·
10,538 Posts
Re: CEL

Air Fuel Ratios.


thats what it means by running lean. there's too little fuel, and too much air in your mixture of gas//air that goes into the cylinder for combustion
 

·
Registered
Joined
·
10,239 Posts
Discussion Starter #8
Re: CEL

Makes perfect sense as I thought I was just getting to much air into my engine. What can be causing to little fuel and too much air?
 

·
Registered
Joined
·
10,538 Posts
Re: CEL

well, considering you don't have mods. i have no idea. your ecu may need to be tweaked. thats about all i can think of?

you might have a leak in a fuel line somewhere. idk! there's a million possibilities. sorry man. :?


if you had mods, that would've been my first guess. thats why turbo guys get bigger injectors, that add more fuel because of all the extra air
 

·
Registered
Joined
·
472 Posts
Re: CEL

number of things. try cleaning your MAF sensor, or it could be your o2 sensor is faulty. Also cleaning injectors might help.

is this on a new car? or the one that was hit?
 

·
Registered
Joined
·
10,538 Posts
Re: CEL

your fuel pump might be bad?
 

·
Registered
Joined
·
10,239 Posts
Discussion Starter #12
Re: CEL

its on my 05 mazda3, fairly new... and yes this is the one that got hit.

yeah i heard it could be my fuel pump as well.... i have to go to the dealership as soon as i get my bumper fixed
 

·
Registered
Joined
·
10,538 Posts
Re: CEL

Good luck, hopefully its nothing bad
 

·
Registered
Joined
·
6,352 Posts
Re: CEL

[quote author=BoostThat3 link=topic=66559.msg1141870#msg1141870 date=1168400457]
Well, I got a CEL today and brought it to have it scanned. The 3 codes read: P2187 - System to lean @ idle and P2177 - System to lean off idle speed. The first code (P2187) was thrown twice out of the three codes.

Does anybody know what this could be? I was told it can be a multiple amount of things. That I wouldn't be able to find out exactly what's wrong unless I get the real, whole engine diagnostic for $85... suggestions?
[/quote]

if everything's basically stock, it could just be the ECU opening the TB too much. If you have a CAI, the MAF sensor's probably too cold.
 

·
Registered
Joined
·
12,565 Posts
Re: CEL

[quote author=thebeansoldier link=topic=66559.msg1142014#msg1142014 date=1168404746]
[quote author=BoostThat3 link=topic=66559.msg1141870#msg1141870 date=1168400457]
Well, I got a CEL today and brought it to have it scanned. The 3 codes read: P2187 - System to lean @ idle and P2177 - System to lean off idle speed. The first code (P2187) was thrown twice out of the three codes.

Does anybody know what this could be? I was told it can be a multiple amount of things. That I wouldn't be able to find out exactly what's wrong unless I get the real, whole engine diagnostic for $85... suggestions?
[/quote]

if everything's basically stock, it could just be the ECU opening the TB too much. If you have a CAI, the MAF sensor's probably too cold.
[/quote]

Last I checked, he doesn't have a CAI.
 

·
Registered
Joined
·
10,239 Posts
Discussion Starter #17
Re: CEL

yeah, I don't have a CAI or anything in my engine aftermarket other than a K&N Air Filter... Now that I'm more aware of it I took it for a ride, and when I step on the trottle, I hear this very soft clatter/rattle noise. It's not loud at all, if I have my radio on at volume #3, can't hear the clatter. Anyways, all I can do right now is take it slow and wait until Tuesday to bring my car to get it fixed from the body shop. Then I bring it to the dealer. Thanks for all the help.. feel free to add in your suggestions or anything you may think is wrong. I don't want to pay $85 at Pep Boys for an engine analysis just to find out what it is.
 

·
Registered
Joined
·
704 Posts
Re: CEL

i know that noise. i have that too but its there sometimes and not others. but sometimes when the car is running great too its there. i dont know what it is.. i should check on that now that i think of it. however your codes are identical to the tsb on purge valve replacements i have seen for those types of codes. look at the one with all the tons of codes listed.
 

·
Registered
Joined
·
10,239 Posts
Discussion Starter #19
Re: CEL

Got the car back, it's fixed.. and the CEL is gone. It was the throttle body screw, someone tampered with it.. so that's fixed, BUT.. got the car back, now there's this MAJOR VIBRATION. I knew exactly what it was at first, thought it was the rear motor mount.. I was wrong.

Well.. I figured out what it was.. LOL look at this thing.. it's the passenger side main motor mount! The thing shattered! It was taken off and little poly urethane or rubber peices went everywhere like it was shattered!??! :bitching:

How it's supposed to look, but attached:


Detached..
 

·
Registered
Joined
·
10,538 Posts
what?

it looks fine!

:Ownedcrazy:
 
1 - 20 of 32 Posts
Top