Mazda3 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter · #1 ·
Ok guys. I could really use your help on this. Driving home from work yesterday and my CEL came on. I wasn't driving it hard or anything. So I took it to AutoZone by my house and the guy told me he wasn't going to check it unless I checked it at the dealer. I was like wtf?! So I headed to the AutoZone by my girlfriend's house and the guy there ran the code retrieval thing and he said 3 codes popped up. These are the codes:

P0103 - Open or Short circuit condition
- Poor electrical connection
- Faulty Mass Air Flow sensor

P0126 - Low Coolant Level
- Open or Short circuit condition
- Faulty ECT Sensor

P0128 - same as P0126


I checked and I have plenty of coolant It's actually a little over the max.
I just bought my car two weeks ago and the guy who owned it before me apparantly lived in Minnesota. Do you think It could just be that the coolant in there is for use in colder weather? Because I live in Texas, so I was wondering if climate had anything to do with it.

Any information or help you guys have would definitely be appreciated. And it may be as simple as changing my MAF sensor and my ECT sensor. If so, how hard is it to change my MAF and ECT sensors?
 

·
Registered
Joined
·
10,739 Posts
It's more likely that the MAF wiring is loose or damaged, than the actual sensor is bad... I would get that checked out first.
 

·
Registered
Joined
·
72 Posts
Discussion Starter · #3 ·
I didnt even think about that. I just got it like two weeks ago and it came with an Injen CAI. I 'll check the wiring tonight. Thank you.

Btw, I saw all of your pictures last night, your car is amazing! In case you didnt already know lol
 

·
Registered
Joined
·
10,739 Posts
I used to have an Injen CAI and the same thing happened, that's why I suggested the possibility. And thanks, I do know but it's nice to hear it from others ;)
 
1 - 4 of 4 Posts
Top