Mazda3 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
390 Posts
Discussion Starter · #1 ·
This weekend i was runnin neons thru the car had everything set up nice took the car out later that night and noticed it was runnin like crap. At idle the rpm's would be jumpy and the car would start to buck like it was about to stall. When i was comin up to my driveway i had the clutch in and puttin it into neutral and then the car shut off. Today i was driving around campus and it was acting up again. Both times i was at a stop sign waiting to go and the car stalled. I didnt let the clutch out or anything. Does anybody no wat is causing this. I got an intake and an exhaust if that matter. Thanks for the help.
 

·
Registered
Joined
·
10,739 Posts
Sounds like your MAF is not hooked up correctly. It's the little black plastic square with a hollow cylinder going down into your intake. Check that the wiring harness attached to it is secure, there are no air leaks, and no wires have came loose, etc.
 

·
Registered
Joined
·
390 Posts
Discussion Starter · #3 ·
yea that should b all good..it ran fine before i started messin wit the neons and i didnt touch the sensor,but yea ill check it tom. Coudl it just b the battery resettin itself still since i had to disconnect it?
 

·
Registered
Joined
·
1,438 Posts
[quote author=guido08 link=topic=137384.msg2961959#msg2961959 date=1235616331]
yea that should b all good..it ran fine before i started messin wit the neons and i didnt touch the sensor,but yea ill check it tom. Coudl it just b the battery resettin itself still since i had to disconnect it?
[/quote]

Try running it without the neons... for so, so many reasons. The battery or alternator could be crapping-out on you, so you might want to have it tested.

If the alternator is giving up the ghost, the car will run like shit. Is your CD player skipping or anything like that?
 

·
Registered
Joined
·
390 Posts
Discussion Starter · #5 ·
Try running it without the neons... for so, so many reasons. The battery or alternator could be crapping-out on you, so you might want to have it tested.

If the alternator is giving up the ghost, the car will run like shit. Is your CD player skipping or anything like that?
[/quote]


Well i havent even been runnin the neons. So ur sayin to disconnect them and see hhow it runs after that?
 

·
Registered
Joined
·
1,438 Posts
[quote author=guido08 link=topic=137384.msg2962086#msg2962086 date=1235619199]
Well i havent even been runnin the neons. So ur sayin to disconnect them and see hhow it runs after that?
[/quote]

Well, its possible you have a short somewhere that is draining your battery. Since the car was behaving prior to putting in your lights, disconnecting and removing the CCFLs could uncover what is afoot.
 

·
Registered
Joined
·
390 Posts
Discussion Starter · #7 ·
Today i went for a drive and everythin was normal. The sputtering and everything stop and didnt stall or anything, so mayb it was just a fluke. THanks bicycle_wreck for helping out. Hopefully the car doesnt act up again.
 
1 - 7 of 7 Posts
Top