Mazda3 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
I originally posted this in the wrong section.

I have a 2006 2.3L w/ 91k miles. About 2 weeks ago I tried to start my car and I could hear the starter turning but the engine wouldn't start. I turned key to off and tried again and it started no problem. Ever since then the first time I try to start the car it won't kick on but the second time it always comes on. If I make a short stop and engine is still hot when I try to start it, it usually starts no problem. Sometimes on second effort to start it, it chugs a bit, struggling, but then reaches idle and sounds normal. I had battery and alternator tested and both checked good.

If it was starter, I'd think it would happen all the time or more randomly than every time I try a cold start. Possibly fuel pump losing prime? Any ideas?
 

·
Registered
Joined
·
2 Posts
Have you changed your spark plugs? My previous 2004 3i was hard starting right around 90k miles, until I changed my original set. The car never misfired or else I would haves changed them earlier...
 

·
Registered
Joined
·
20 Posts
Discussion Starter #3
I haven't changed the plugs. Will be doing that next week as I'm overdue. Would bad plugs be as regular as my symptoms are, though? Won't start on first attempt but starts second time always...
 

·
Registered
Joined
·
120 Posts
Maybe it's a fuel pump issue? Your first start pressurized the fuel system enough so that it's easier to start the second time.

Do you have issues with misfires when you accelerate at full throttle or climbing a steep hill?

You can also try to prime the pump first by turning the key to 'on' (don't actually start it), wait a few seconds to let the fuel pump work, then start the car. If the car starts every time, then I'd be more confident that it's the fuel system rather than the ignition system.
 
1 - 5 of 5 Posts
Top