Mazda3 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Just bouy my daughter a used 2005 Mazda3. No fobs came with it. I checked and it does have the KEU in the headliner. I ordered fobs. However I can't get it to go into programming mode. Did the 3x3 dance and no lock-unlock signal. Tried both keys. Both keys start the car.

Checked all the fuses. The locks work fine with interior button and using the key.

Never even got to try the fob as it wouldn't ebter programming mode.

What else should I try?
 

·
Registered
Joined
·
90 Posts
Would you confirm that you've exactly performed the procedure in the top image here?:
If you're exactly performing that, within the specified time limits, note that there's a troubleshooting table on the 3rd image of that album.
 

·
Registered
Joined
·
32 Posts
Hi, were u able you finally to program the new fob?. I'm having the same issue, 04 mazda 3 came with one control, recently one of the bottons on the fob board came loose and try to do the dance and couldn't get it into programming mode. I called an locksmith, he came over, did the dance for like 40 mins... without good results. He said may something was wrong with the ignition cylinder....I was like...not idea.
 

·
Registered
Joined
·
90 Posts
Hi, were u able you finally to program the new fob?. I'm having the same issue, 04 mazda 3 came with one control, recently one of the bottom on the fob board came loose and try to do the dance and couldn't get it into programming mode. I called an locksmith, he came over, did the dance for like 40 mins... without good results. He said may something was wrong with the ignition cylinder....I was like...not idea.
Share a video of you performing the procedure and we can assess for issues with timing or steps. "One of the bottom on the fob board came loose" doesn't make sense -- one of the what on the bottom? The switches/buttons? Do the other buttons work?

It's all guesswork if we can't see what you're working with.
 

·
Registered
Joined
·
32 Posts
Share a video of you performing the procedure and we can assess for issues with timing or steps. "One of the bottom on the fob board came loose" doesn't make sense -- one of the what on the bottom? The switches/buttons? Do the other buttons work?

It's all guesswork if we can't see what you're working with.
I followed this video to the dot and still nothing, i believe it can actually be an issue with the ignition cylinder, not making the right contacts or something. This is what I was referring to, I ended resoldering it to the circuit board and is working now. But still need to find a way to add at least one more key fob.
105836

 

·
Registered
Joined
·
90 Posts
In that Imgur link from my old post above, the "on-board diagnostic" procedure is the 3rd image down. If you perform that process, paying careful attention to the timing (especially the wait-time, if you make a mistake in the process), what is your exact result?
 
1 - 6 of 6 Posts
Top