Mazda3 Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
296 Posts
Discussion Starter · #1 ·
Bought my Mazda 3 early last month and never had a chance to post any pictures or even announce *officially* that I owned a Mazda 3 on this board. eh! :)

Tit. Grey Color
2.3L
Sport Package
Moonroof / 6 CD changer package
ABS Braking System

No Nav. System and Xeon light package, because the dealer doesn't have that stocked with the car on the color I want, and I was in a rush buying a new car because my old 95 Sentra decided to die on me, and I need a car to get me to work.

So-far, I have about 3100 milages on it already. YUP! I put about 3100 milages just a little 1 month and 1/2! I drove about 70 miles per day round trip and weekend, I hang around in Boston which is about 70 miles round trip also.

YUP! Problems on my car like everyone else...
Airbag, ABS, and Brake lights came on, but all fixed.
Still waiting for new brakes though, it's in backorder.
New problem on my car just recently, my seatbelt light doesn't come on all the time when I take my seatbelt off, so I might need to inform the dealer that when I bring my car to get the brakes replace

oh! Just a side notes: My driveway has a Mazda 03 Protege 5 (drove by my mom), a Mazda 04 Protege (drove by my dad), and a Mazda 3 (drove by me). Mazda Family!!!
AND my dad's 92 Mazda Protege officially retired and get donated last Summer and get it replaced by the 04 Protege that he's driving now.

Pictures on next post... :)
 

·
Registered
Joined
·
296 Posts
Discussion Starter · #4 ·
Re: Nice and congrats

Ho Fi MZ-3 said:
Wow sweet ride and pics. How come so may problems with the car so soon such as brakes and such? How much did you pay?
Have fun!! :)
I paid almost 20k out the door, but not over 20k.
I used the S-Plan and the recent graduate rebate. :)

and car problems, I don't know, it's just acting on me. Maybe because it is a first year model.
 

·
Registered
Joined
·
296 Posts
Discussion Starter · #6 ·
Just a head's up
My car is heading back to the dealer this Wednesday.

1) Replacement for my old brakes with new ones, because it made noises.
2) Seatbelt sensor is not working properly. Sometime the seatbelt sensor doesn't light up when I take my seatbelt off.
3) My car rattles for 3 secs before it can actually start up, that happens about 3 out of 10 start-up

::sign:: This is already the 2nd time I'm bring back my car to resolve some minor problems. Hopefully after this, my car will be all set!
 

·
Registered
Joined
·
296 Posts
Discussion Starter · #9 ·
This is sad... I took my car to dealer, and they give me a KIA for me temporary. Why KIA? I don't mind driving like a 02' or 03' protege, but why KIA!? :( :(

BTW, KIA does sucks, nothing compare with Protege nor Mazda 3.
 

·
Registered
Joined
·
296 Posts
Discussion Starter · #11 ·
prismglass said:
uh oh. I've got a titanium gray 3s sedan with a build date of 11/03. What type of noises were the brakes making? Squeals, hums, whistles???
oh it's squeaking noises when i step on my brakes. That happens usually the first time I step on my break after after starting up my car.

My dealer replaced all my brakes for me which is cool. :)

but I still have to fix my cranking problem, bringing it back in again on Monday! Hopefully I'll get it fix this time.
 

·
Registered
Joined
·
1 Posts
Hi there,

I also have a Titanium Grey MZ3 GT (2.3L) and I noticed recently that my brakes are also "squeaking" sometimes.

My dealer told me that it was because the brakes are "trempés" (tempered ? is this the right word ? (excuse my english :wink: )) and dust and cold weather made them "squeak".

Since I haven't experienced any braking degradation I'd tend to beleive them, however, did you hear anything else on this ? I'm curious.

Other than that the only "real" problem I had has been the CE light. Fixed in 10 minutes by the dealer.
 

·
Registered
Joined
·
296 Posts
Discussion Starter · #13 ·
Sefirosu said:
Hi there,

I also have a Titanium Grey MZ3 GT (2.3L) and I noticed recently that my brakes are also "squeaking" sometimes.

My dealer told me that it was because the brakes are "trempés" (tempered ? is this the right word ? (excuse my english :wink: )) and dust and cold weather made them "squeak".

Since I haven't experienced any braking degradation I'd tend to beleive them, however, did you hear anything else on this ? I'm curious.

Other than that the only "real" problem I had has been the CE light. Fixed in 10 minutes by the dealer.
They replaced my brakes for me, that's what they did for me.
 
1 - 13 of 13 Posts
Top