Mazda3 Forums banner
1 - 2 of 2 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
News to the Mazda 3 platform.

Bought an '06 with trans and check engine light. Bought a new TCM and replaced it. Still got Solenoid E code.

Replaced solenoid e and the one next to it. Still not fixed. Symptoms: Hard shift into reverse (if I clear there codes with my Blue Driver, there is a shoot second where I can shift into reverse without issue), and the dash doesn't show any indication off great when in manual mode. However in "D" mode, the dash shows which gear the trans is in ( but I think it is supposed to showa"D."

I've replaced the sensors on the front of the trans and at the back. I didn't change the to one. No change.

I also tried to clear the codes and when the church engine/AT lights go out for split second, I can put it into manual mode. It will show first gear until I try to upshift and then it throws codes again.

Thoughts?
 

· Registered
Joined
·
406 Posts
If over 100K and not serviced at least once between 40-50K there may be some varnish built up effect the operation of valves and other parts that fluid flow is important. The only real way to determine this would be inspecting what was in the pan and also having the oil checked by way of oil analysis. The cost is about 30 USD and well worth knowing the information. If there is nothing of great concern in the fluid sample, you could think about doing a full transmission positive flush cleaning and replacement fluid?
 
1 - 2 of 2 Posts
Top