Mazda3 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
So after a very long ordeal on my 3, it seems like it not acelerating like it used to.. I also got the code P2006, seems like when the VVT kicks @5000 and not as smooth. Anybody got any clues on what's going on??? Thanks.........

2006 5dr, 2.3.........
 

·
Registered
Joined
·
4,781 Posts
found this:
"P2006 Variable tumble control system (VTCS) shutter valve stuck closed ON 2 CCM ´ (See DTC P2006)"

sounds like its you emissions controls causing problems for you
 

·
Registered
Joined
·
9,451 Posts
Yeah the tumble valves getting stuck closed would DEFINITELY kill performance. I suggest high tailing it to the dealership and having them fix it. That or you could just go ahead and remove the tumble valves.
-Matt
 

·
Registered
Joined
·
9,388 Posts
i just got back from the dealership to get my windshield wiper fix (the one time we get ice in dallas, my wiper gets stuck to the windshield and strips the arm so it wont turn) and i met a mz3 guy who was talking to a tech that was having this same problem. they didn't fix it because of his intake because they said they can't get an accurate diagnosis with it on so they told him to put the stock intake back on before they could be sure. i believe this was the code it was throwing. the description sounds right.

oldyota83, where they able to fix your problem?

the reason why i mention all this is because the tech was telling me that he reports directly to engineers regarding stock issues. he said the dealership, freeman mazda in irving, tx, is one of 25 dealerships that gives feedback to mazda engineers. not sure if he's full of crap or not but in any case, he hasn't heard of this problem so i at least wanted to research it because it seems like a lot of people are having this problem.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #6 ·
I got it fixed, I had some major motor issues and so after putting everything back together I had the wires swapped on the VTCS two soleniods... That kept the valve stuck in the closed position, when I switched the wires the valve opened.... Test drove it and it wanted to smoke the tires, and then the CEL even went off without evening clearing it....
 
1 - 6 of 6 Posts
Top