Mazda3 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I just got my new-to-me 2004 Mazda 3 Hatchback with the 2.3 and the 5 speed. With 208k on the odometer, she still seems to be running strong. The previous owner replaced the transmission and clutch last November. It's a great car and quite the upgrade compared to my previous 2007 Silverado 1500 Classic, especially in the interior. There are a few things wrong with her, however. Firstly, the front struts are shot which I new going in. Have them sitting in my garage waiting to be installed. Secondly, the passenger side lowbeam socket is completely gone and some hideous frankenconnection thing is going on because the previous owner decided he didn't want to use an h7 bulb on that side. :madthrow: This frankenconnection also doesn't get power, so I'm hoping it just blew the fuse for that side and not something worse. Thirdly the previous owner installed an after market head unit. Then tore the volume knob out of it. Also the lcd screen that goes above it missing. Not too worried about this unless it does something REALLY cool/important. I also can't use the steering wheel controls to control the volume because apparently nothing on my steering wheel works. Stuff on the column is fine, but steering wheel stuff doesn't work. Not even the horn. Lastly, in low gears at low rpm's the car is kinda surgey. Not sure if an issue or my general inexperience with MT operation.

None of the issues, except the struts, are super serious and I can live with since this car only exists to drive me to work and back. I do plan on fixing them though. Slowly but surely.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #2
More stuff!

A quick question though: how the heck do you reset the trip meter? I can't figure that out for the life of me.
 

·
Registered
Joined
·
711 Posts
A quick question though: how the heck do you reset the trip meter? I can't figure that out for the life of me.
Press and hold till it clears.
Welcome, I've owned 2 2004 hatches-great cars. If you didn't already know, the hatch and sedan headlights are different. So when you start looking......
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Press and hold till it clears.
Welcome, I've owned 2 2004 hatches-great cars. If you didn't already know, the hatch and sedan headlights are different. So when you start looking......
Thanks! I guess I figured that. I just can't seem to find the thing to press. Guess I'll take a closer look at it Wednesday when I replace the struts.
 

·
Registered
Joined
·
711 Posts
On the speedo pods, between the center pod and the right side pod at the top you will see a black plastic rod thing. That's what you push.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
On the speedo pods, between the center pod and the right side pod at the top you will see a black plastic rod thing. That's what you push.
Thanks!
 
1 - 6 of 6 Posts
Top