Mazda3 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I purchased the car 3 months ago from a dealership and it appeared to have new from struts installed. After 2 months the sway bar started making contact with the under body ( slight clung sound) whenever the car is driven over slight dips in the road. I have re-centered the sway bar multiple times but within a few days its moved 2+ inches to the left. The right side swaybar link end has moved left 2+ inches. I'm wondering if one of the struts was installed incorrectly putting pressure on the sway bar.
 

·
Registered
Joined
·
521 Posts
How many miles on the car? I'm thinking the bushings could be worn as well as the swaybar links. I replaced the links and bushings when I did the struts a couple of years ago. Makes a BIG difference in the vehicle's handling.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I purchased the car 3 months ago from a dealership and it appeared to have new from struts installed. After 2 months the sway bar started making contact with the under body ( slight clung sound) whenever the car is driven over slight dips in the road. I have re-centered the sway bar multiple times but within a few days its moved 2+ inches to the left. The right side swaybar link end has moved left 2+ inches. I'm wondering if one of the struts was installed incorrectly putting pressure on the sway bar.
Car has 167,000 miles. I'm replacing the sway bar links next weekend. I notice that one link has small split in the rubber. On another subject, I starting to hear timing chain rattle from time to time and evaluating whether to replace the engine with low mileage 2.5L or just install a new timing chain. I'm the second owner have records showing previous owner changed oil and other maintenance items on schedule. The car doesn't use oil between changes. I plan on keeping the car for sometime but, definitely should do one or the in the next few months.
 

·
Registered
Joined
·
521 Posts
Pull the spark plugs to verify the valve cover gasket isn't leaking. If the car isn't burning oil, I see no need to replace the engine unless you're itching to do it for fun.
 
1 - 4 of 4 Posts
Top