Mazda3 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey everyone, I just installed a BOSS Elite BV850ACP and I’d like to keep the stock LCD screen that shows the temp and fuel information. I’ve been looking everywhere on how to do this but can’t find anything. Has anyone done this before or have any idea on how to make this work?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
4 Posts
Have you tried calling Crutchfield? They are 💯 the BEST! They’re not only kind, and patient but they know their sh**! They’ll know and have exactly what you need and they’ll walk you through the process step by step. They were also kind enough to price match something I found cheaper on Amazon, so don’t worry that they’re just trying to take your money. Call them and just let them send you what they recommend when you’re ready to hook it up, you can call them back for anything. I called as soon as I opened it 1-844-610-4750 (Crutchfield)
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Have you tried calling Crutchfield? They are the BEST! They’re not only kind, and patient but they know their sh**! They’ll know and have exactly what you need and they’ll walk you through the process step by step. They were also kind enough to price match something I found cheaper on Amazon, so don’t worry that they’re just trying to take your money. Call them and just let them send you what they recommend when you’re ready to hook it up, you can call them back for anything. I called as soon as I opened it 1-844-610-4750 (Crutchfield)
Oh awesome, I didn’t even think about that. Thank you!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
4 Posts
Oh awesome, I didn’t even think about that. Thank you!


Sent from my iPhone using Tapatalk
I’m a hardcore DIY’r so I was set on installing it myself! It was just killing me that I had no idea what to do but I stumbled upon them and I’m so grateful that I did!
I have a question that maybe you could help me with... I cannot get any picture on my Pioneer ACH-1400NEX (that’s not really all that important though) I installed the back up camera to the HU and ran the wires through the entire body of my cx-7. It was not easy! I was a hot mess after hours of struggling with getting those wires through all the panels in the 90• weather and it doesn’t work, like at all!!! I can’t even get any videos to come up even with the prk break bypass installed correctly. I thought, ok, so let’s engage the prkg break... still nothing!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Oh I haven’t installed the backup camera yet since I need to get more cable to reach up into the hatch to trigger it off the reverse lights. Did you hook the camera up to your reverse lights to power the camera?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
4 Posts
Oh I haven’t installed the backup camera yet since I need to get more cable to reach up into the hatch to trigger it off the reverse lights. Did you hook the camera up to your reverse lights to power the camera?


Sent from my iPhone using Tapatalk
No, because it’s supposedly getting it’s power and reverse response indicator(or whatever it’s called), directly from the HU. Now my microphone isn’t working either! Ughhh! So frustrating! I must have loosened the connection when I was checking the prk break bypass. Now I have to remember where the wire to the mic goes. Hopefully it’s just loose and not pulled out because then I’ll just secure it. I’ve blown a fuse, disconnect the mic, who knows what else. I feel like it’s always something!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
It definitely is always something lol. But I’m sorry I don’t know more just yet since i haven’t done it. Once I do install it I’ll let you know what I find out.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
29 Posts
I just looked at that exact unit AND I looked at it on Crutchfield! I don't want to lose that part of my display either. I use the heck out of that when I've driving the Mazda, and that is seriously one of the reasons I haven't already upgraded.
 
1 - 8 of 8 Posts
Top