Mazda3 Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hey all, new member here.

I have a 2005 SP23, with just about 50k on it.

Today I noticed some hesitation with accelerating. 1st seems ok, but it kind of lags somewhat transitioning to 2nd and into third. Or sometimes 2nd will pull good, but then 3rd hesitates.

I am not sure what causes this problem, just looking to see if anyone has any suggestions?

My first thought was clutch, slave solenoid or pressure plate. My second thought was ignition coils, but that doesn't seem right MPG seemed about the same.

Sorry for not searching through the forum first, I am hoping to get some cues and suggestions now before later.
 

·
Registered
Joined
·
31,083 Posts
welcome to the forums. Has the tranny fluid been flushed, or have you checked the condition of the fluid?
i am assuming from your description that you have an axt and many seem to report odd issues going away after replacing the fluid.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
[quote author=ballinpapo link=topic=139515.msg3007598#msg3007598 date=1237593023]
change your transmission fluid :lol:
[/quote]

I don't think tranny fluid is the problem, honestly. But I take it the dealer will probably sort it out.
 

·
Registered
Joined
·
31,083 Posts
there may be a pcm update available as well...have you owned the car the entire 50k, and just noticed these symptoms, or is the car new to you?
 

·
Registered
Joined
·
887 Posts
[quote author=Breakaway23 link=topic=139515.msg3007608#msg3007608 date=1237593177]
[quote author=ballinpapo link=topic=139515.msg3007598#msg3007598 date=1237593023]
change your transmission fluid :lol:
[/quote]

I don't think tranny fluid is the problem, honestly. But I take it the dealer will probably sort it out.
[/quote]



it probably is.. that is a common sign that your tranny fluid is old.. your supposed to change it every 30,000k miles atleast. and most people overlook it..


it happened to me at 25k and i changed my fliuid and the car felt new..
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #8 ·
[quote author=John_in_the_LBC link=topic=139515.msg3007619#msg3007619 date=1237593636]
there may be a pcm update available as well...have you owned the car the entire 50k, and just noticed these symptoms, or is the car new to you?
[/quote]

Car is pretty much new to me, got it at 42k. PCM update available? Can you elaborate more?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #9 ·
[quote author=ballinpapo link=topic=139515.msg3007628#msg3007628 date=1237593857]
[quote author=Breakaway23 link=topic=139515.msg3007608#msg3007608 date=1237593177]
[quote author=ballinpapo link=topic=139515.msg3007598#msg3007598 date=1237593023]
change your transmission fluid :lol:
[/quote]

I don't think tranny fluid is the problem, honestly. But I take it the dealer will probably sort it out.
[/quote]



it probably is.. that is a common sign that your tranny fluid is old.. your supposed to change it every 30,000k miles atleast. and most people overlook it..


it happened to me at 25k and i changed my fliuid and the car felt new..
[/quote]

Hmmm... Might look into it, but this would be the first manual that would be changed with 30,000k on it. I have never had that be the problem on any previous MT car I have had before.
 

·
Registered
Joined
·
887 Posts
[quote author=Breakaway23 link=topic=139515.msg3007632#msg3007632 date=1237594006]
[quote author=John_in_the_LBC link=topic=139515.msg3007619#msg3007619 date=1237593636]
there may be a pcm update available as well...have you owned the car the entire 50k, and just noticed these symptoms, or is the car new to you?
[/quote]

Car is pretty much new to me, got it at 42k. PCM update available? Can you elaborate more?
[/quote]

i keep telling you change the stupid tranny fluid.. lol
 

·
Registered
Joined
·
31,083 Posts
[quote author=Breakaway23 link=topic=139515.msg3007638#msg3007638 date=1237594113]
[quote author=ballinpapo link=topic=139515.msg3007628#msg3007628 date=1237593857]
[quote author=Breakaway23 link=topic=139515.msg3007608#msg3007608 date=1237593177]
[quote author=ballinpapo link=topic=139515.msg3007598#msg3007598 date=1237593023]
change your transmission fluid :lol:
[/quote]

I don't think tranny fluid is the problem, honestly. But I take it the dealer will probably sort it out.
[/quote]



it probably is.. that is a common sign that your tranny fluid is old.. your supposed to change it every 30,000k miles atleast. and most people overlook it..


it happened to me at 25k and i changed my fliuid and the car felt new..
[/quote]

Hmmm... Might look into it, but this would be the first manual that would be changed with 30,000k on it. I have never had that be the problem on any previous MT car I have had before.
[/quote]

OK so it's an MTX....

I meant that some earlier models had some issues that were resolved with new programming for the engine management system. I don't remember if it applies to your year and model and transmission. If you take it to the dealer they should know.
 
1 - 12 of 12 Posts
Top