Mazda3 Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi all
My Girlfriend owns a 2008 Mazda 2 1.3
107000km on the clock

So, this morning, I fire it up, and it just misfires and die.

I crank it again, and the motor spin freely, so free that I thought the solenoid packed up. I then checked and the pulleys’ are all turning.

Things I’ve checked

1. Enough petrol in the tank
2. Fuses
3. The Petrol pump does kick in when ignition on and then shut off after a few seconds like it should
4. Air intake is not obstructed
5. No check engine light


I can confirm that the fuel pump and relay is working, I don’t have a fuel pressure gauge, so I can’t confirm if it’s working at the right pressure

I can confirm that it’s not cam belt issue, as there is no strange noise when cranking it and it did fire up and idle for a few seconds, with allot of “splatter” and then died

I wanted to check the plugs and plug wires for spark, but I can’t get the air cleaner assembly removed, there are some sensors attached to it and I don’t have tools to remove it.

Any help will be appreciated!!

Thanks
 

·
Registered
Joined
·
4 Posts
Discussion Starter #2
Well, today I pulled the ECU relay, turn ignition on, the lights on the dash go crazy, switch off and put the relay back. Turn ignition on, lights is back to normal, turn key, motor cranks a few times and starts up

Took it for a spin, all is well and its starting again.

Don't know if the temporary removal of the relay had anything to do with or if it was pure luck.
 
1 - 2 of 2 Posts
Top