Mazda3 Forums : The #1 Mazda 3 Forum - Reply to Topic
Thread: NEED HELP!!! Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Mazda3 Forums : The #1 Mazda 3 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
12-12-2019 03:12 PM
.Slug If you can't diagnose it yourself, because this is a such odd behavior, I'd just pay someone to diagnose it. Preferebly a transmission shop familiar with Mazdas. You didn't provide a lot of info here... like how many miles are on the transmission/car. Does the behavior only appear during acceleration or with foot off the gas, or during breaking or?
12-10-2019 09:24 PM
tmooney
NEED HELP!!!

Hey everyone, first post here, having some issues with my 2006 Mazda 3 automatic transmission, it’s doing some weird shit and could use some advice on how to fix, lately it has been randomly downshifting from 5th to 4th and then lunging forward and and then go back into 5th gear, and when all this happens the lights that indicate what gear I am in go out, also having issues with it starting in park, have to start in neutral, could these be associated with eachother???
Thanks

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome
8