A New Car! - Mazda3 Forums : The #1 Mazda 3 Forum
 1Likes
  • 1 Post By Bill
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 03-05-2017, 06:03 AM Thread Starter
Bicycle Rider
 
Lazer_Phazer's Avatar
 
Join Date: Mar 2017
Posts: 5
A New Car!

I just got my new-to-me 2004 Mazda 3 Hatchback with the 2.3 and the 5 speed. With 208k on the odometer, she still seems to be running strong. The previous owner replaced the transmission and clutch last November. It's a great car and quite the upgrade compared to my previous 2007 Silverado 1500 Classic, especially in the interior. There are a few things wrong with her, however. Firstly, the front struts are shot which I new going in. Have them sitting in my garage waiting to be installed. Secondly, the passenger side lowbeam socket is completely gone and some hideous frankenconnection thing is going on because the previous owner decided he didn't want to use an h7 bulb on that side. This frankenconnection also doesn't get power, so I'm hoping it just blew the fuse for that side and not something worse. Thirdly the previous owner installed an after market head unit. Then tore the volume knob out of it. Also the lcd screen that goes above it missing. Not too worried about this unless it does something REALLY cool/important. I also can't use the steering wheel controls to control the volume because apparently nothing on my steering wheel works. Stuff on the column is fine, but steering wheel stuff doesn't work. Not even the horn. Lastly, in low gears at low rpm's the car is kinda surgey. Not sure if an issue or my general inexperience with MT operation.

None of the issues, except the struts, are super serious and I can live with since this car only exists to drive me to work and back. I do plan on fixing them though. Slowly but surely.
Lazer_Phazer is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 03-05-2017, 06:05 AM Thread Starter
Bicycle Rider
 
Lazer_Phazer's Avatar
 
Join Date: Mar 2017
Posts: 5
More stuff!

A quick question though: how the heck do you reset the trip meter? I can't figure that out for the life of me.
Lazer_Phazer is offline  
post #3 of 6 (permalink) Old 03-05-2017, 11:46 AM
Le Mans: GT Class
 
Bill's Avatar
 
Join Date: Dec 2004
Location: San Antonio, Tx
Posts: 704
Garage
Quote:
Originally Posted by Lazer_Phazer View Post
A quick question though: how the heck do you reset the trip meter? I can't figure that out for the life of me.
Press and hold till it clears.
Welcome, I've owned 2 2004 hatches-great cars. If you didn't already know, the hatch and sedan headlights are different. So when you start looking......

Hopeless Gearhead
Bill is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 03-06-2017, 03:06 AM Thread Starter
Bicycle Rider
 
Lazer_Phazer's Avatar
 
Join Date: Mar 2017
Posts: 5
Quote:
Originally Posted by Bill View Post
Press and hold till it clears.
Welcome, I've owned 2 2004 hatches-great cars. If you didn't already know, the hatch and sedan headlights are different. So when you start looking......
Thanks! I guess I figured that. I just can't seem to find the thing to press. Guess I'll take a closer look at it Wednesday when I replace the struts.

One shot, one kill. All luck, no skill.
-Me in every shooting game ever.
Lazer_Phazer is offline  
post #5 of 6 (permalink) Old 03-08-2017, 10:40 PM
Le Mans: GT Class
 
Bill's Avatar
 
Join Date: Dec 2004
Location: San Antonio, Tx
Posts: 704
Garage
On the speedo pods, between the center pod and the right side pod at the top you will see a black plastic rod thing. That's what you push.
GerryBuc likes this.

Hopeless Gearhead
Bill is offline  
post #6 of 6 (permalink) Old 03-14-2017, 05:13 PM Thread Starter
Bicycle Rider
 
Lazer_Phazer's Avatar
 
Join Date: Mar 2017
Posts: 5
Quote:
Originally Posted by Bill View Post
On the speedo pods, between the center pod and the right side pod at the top you will see a black plastic rod thing. That's what you push.
Thanks!

One shot, one kill. All luck, no skill.
-Me in every shooting game ever.
Lazer_Phazer is offline  
Sponsored Links
Advertisement
 
Reply

  Mazda3 Forums : The #1 Mazda 3 Forum > Mazda3 General Discussion > I Just Got my Mazda3/MazdaSpeed3!

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda3 Forums : The #1 Mazda 3 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  LinkBacks (?)
LinkBack to this Thread: http://www.mazda3forums.com/93-i-just-got-my-mazda3-mazdaspeed3/743730-new-car.html
Posted By For Type Date
I Just Got my Mazda3/MazdaSpeed3! [Archive] - Mazda3 Forums : The #1 Mazda 3 Forum This thread Refback 11-06-2017 02:26 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
8